Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "An abstract syntax tree for Python with inference support." |
| 2 | HOMEPAGE = "https://pypi.python.org/pypi/astroid" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "LGPL-2.1-only" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a70cf540abf41acb644ac3b621b2fad1" |
| 6 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 7 | SRC_URI[sha256sum] = "4148645659b08b70d72460ed1921158027a9e53ae8b7234149b1400eddacbb93" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 8 | |
| 9 | inherit pypi python_setuptools_build_meta |
| 10 | |
| 11 | DEPENDS += "\ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 12 | python3-pytest-runner-native \ |
| 13 | python3-wheel-native \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 14 | " |
| 15 | |
| 16 | PACKAGES =+ "${PN}-tests" |
| 17 | |
| 18 | FILES:${PN}-tests += " \ |
| 19 | ${PYTHON_SITEPACKAGES_DIR}/astroid/test* \ |
| 20 | ${PYTHON_SITEPACKAGES_DIR}/astroid/__pycache__/test* \ |
| 21 | " |
| 22 | |
| 23 | RDEPENDS:${PN}:class-target += "\ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 24 | python3-lazy-object-proxy \ |
| 25 | python3-logging \ |
| 26 | python3-six \ |
| 27 | python3-wrapt \ |
| 28 | python3-setuptools \ |
| 29 | python3-typing-extensions \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 30 | " |
| 31 | |
| 32 | RDEPENDS:${PN}-tests:class-target += "\ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 33 | python3-unittest \ |
| 34 | python3-xml \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 35 | " |
| 36 | |
| 37 | BBCLASSEXTEND = "native nativesdk" |