Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "Python library for displaying tabular data in a ASCII table format" |
| 2 | HOMEPAGE = "http://code.google.com/p/prettytable" |
| 3 | LICENSE = "BSD-3-Clause" |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c9a6829fcd174d9535b46211917c7671" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 5 | |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 6 | |
| 7 | SRC_URI[sha256sum] = "9665594d137fb08a1117518c25551e0ede1687197cf353a4fdc78d27e1073568" |
| 8 | SRC_URI += " \ |
| 9 | file://run-ptest \ |
| 10 | " |
| 11 | inherit pypi ptest python_hatchling |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 12 | |
| 13 | do_install:append() { |
| 14 | perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO"` |
| 15 | for f in $perm_files; do |
| 16 | chmod 644 "${f}" |
| 17 | done |
| 18 | } |
| 19 | |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 20 | DEPENDS += "\ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 21 | python3-hatch-vcs-native \ |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 22 | " |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 23 | |
| 24 | RDEPENDS:${PN} += " \ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 25 | python3-compression \ |
| 26 | python3-html \ |
| 27 | python3-importlib-metadata \ |
| 28 | python3-json \ |
| 29 | python3-math \ |
| 30 | python3-wcwidth \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 31 | " |
| 32 | |
| 33 | RDEPENDS:${PN}-ptest += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 34 | python3-pytest \ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 35 | python3-pytest-lazy-fixtures \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 36 | python3-sqlite3 \ |
| 37 | python3-unittest-automake-output \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 38 | " |
| 39 | |
| 40 | do_install_ptest() { |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 41 | install -d ${D}${PTEST_PATH}/tests |
| 42 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 43 | } |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 44 | |
| 45 | BBCLASSEXTEND = "native nativesdk" |