blob: 35e9ab1798e56990511d342861ed91559223025b [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Python library for displaying tabular data in a ASCII table format"
2HOMEPAGE = "http://code.google.com/p/prettytable"
3LICENSE = "BSD-3-Clause"
Andrew Geissler220dafd2023-10-04 10:18:08 -05004LIC_FILES_CHKSUM = "file://LICENSE;md5=c9a6829fcd174d9535b46211917c7671"
Patrick Williams92b42cb2022-09-03 06:53:57 -05005
Patrick Williams39653562024-03-01 08:54:02 -06006
7SRC_URI[sha256sum] = "9665594d137fb08a1117518c25551e0ede1687197cf353a4fdc78d27e1073568"
8SRC_URI += " \
9 file://run-ptest \
10"
11inherit pypi ptest python_hatchling
Patrick Williams92b42cb2022-09-03 06:53:57 -050012
13do_install:append() {
14 perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO"`
15 for f in $perm_files; do
16 chmod 644 "${f}"
17 done
18}
19
Andrew Geisslerc5535c92023-01-27 16:10:19 -060020DEPENDS += "\
Patrick Williams73bd93f2024-02-20 08:07:48 -060021 python3-hatch-vcs-native \
Andrew Geisslerc5535c92023-01-27 16:10:19 -060022"
Patrick Williams92b42cb2022-09-03 06:53:57 -050023
24RDEPENDS:${PN} += " \
Patrick Williams39653562024-03-01 08:54:02 -060025 python3-compression \
26 python3-html \
27 python3-importlib-metadata \
28 python3-json \
29 python3-math \
30 python3-wcwidth \
Patrick Williams92b42cb2022-09-03 06:53:57 -050031"
32
33RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060034 python3-pytest \
Patrick Williams39653562024-03-01 08:54:02 -060035 python3-pytest-lazy-fixtures \
Patrick Williams73bd93f2024-02-20 08:07:48 -060036 python3-sqlite3 \
37 python3-unittest-automake-output \
Patrick Williams92b42cb2022-09-03 06:53:57 -050038"
39
40do_install_ptest() {
Patrick Williams39653562024-03-01 08:54:02 -060041 install -d ${D}${PTEST_PATH}/tests
42 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
Patrick Williams92b42cb2022-09-03 06:53:57 -050043}
Patrick Williams39653562024-03-01 08:54:02 -060044
45BBCLASSEXTEND = "native nativesdk"