blob: 7d349b94e4672125c3ad36305e9058e25d8b1ba3 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
2HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
3LICENSE = "LGPL-2.1+"
Brad Bishopb809eb92019-09-18 06:27:43 -04004LIC_FILES_CHKSUM = "file://COPYING;md5=57d09285feac8a64efa878e692b14f36"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005SECTION = "net"
Brad Bishopb809eb92019-09-18 06:27:43 -04006
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007DEPENDS = "file"
8
Brad Bishop26bdd442019-08-16 17:08:17 -04009SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz"
Brad Bishopb809eb92019-09-18 06:27:43 -040010SRC_URI[md5sum] = "ce4050e75cc40d68506e2b403e1a76f9"
11SRC_URI[sha256sum] = "4e66d4db1574f4912fbd2690d10d227cc9cc56df6a10aa8f4fc2da75cea7ab1b"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012
13inherit autotools lib_package pkgconfig gettext
14
15CFLAGS += "-pthread -D_REENTRANT"
16
17EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../"
18
19PACKAGECONFIG ?= "curl https"
20PACKAGECONFIG_append_class-target = "\
21 ${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)} \
22"
23PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
24PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
25PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls,"
26
27do_compile_append() {
28 sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
29}