Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Linux Key Management Utilities" |
| 2 | DESCRIPTION = "\ |
| 3 | Utilities to control the kernel key management facility and to provide \ |
| 4 | a mechanism by which the kernel call back to userspace to get a key \ |
| 5 | instantiated. \ |
| 6 | " |
| 7 | HOMEPAGE = "http://people.redhat.com/dhowells/keyutils" |
| 8 | SECTION = "base" |
| 9 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 10 | LICENSE = "LGPL-2.1-or-later & GPL-2.0-or-later" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | |
| 12 | LIC_FILES_CHKSUM = "file://LICENCE.GPL;md5=5f6e72824f5da505c1f4a7197f004b45 \ |
| 13 | file://LICENCE.LGPL;md5=7d1cacaa3ea752b72ea5e525df54a21f" |
| 14 | |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 15 | inherit manpages ptest |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 16 | |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 17 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/dhowells/keyutils.git;protocol=https;branch=master \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | file://keyutils-test-fix-output-format.patch \ |
| 19 | file://keyutils-fix-error-report-by-adding-default-message.patch \ |
| 20 | file://run-ptest \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 21 | file://fix_library_install_path.patch \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 22 | file://0001-tests-toolbox.inc.sh-update-regex-for-getting-endian.patch \ |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 23 | file://0001-Adhere-to-the-SOURCE_DATE_EPOCH-standard.patch \ |
| 24 | file://0001-tests-builtin_trusted-Failure-command-is-failed.patch \ |
| 25 | file://0002-tests-Use-head-n1-for-busybox-compatibility.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 26 | " |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 27 | SRCREV = "cb3bb194cca88211cbfcdde2f10c0f43c3fb8ec3" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 28 | |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 29 | S = "${WORKDIR}/git" |
| 30 | |
| 31 | PACKAGECONFIG ?= "" |
| 32 | PACKAGECONFIG[manpages] = "" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 33 | |
| 34 | EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} -Wall' \ |
| 35 | NO_ARLIB=1 \ |
| 36 | BINDIR=${base_bindir} \ |
| 37 | SBINDIR=${base_sbindir} \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 38 | LIBDIR=${libdir} \ |
| 39 | USRLIBDIR=${libdir} \ |
| 40 | INCLUDEDIR=${includedir} \ |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 41 | ETCDIR=${sysconfdir} \ |
| 42 | SHAREDIR=${datadir}/keyutils \ |
| 43 | MANDIR=${datadir}/man \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 44 | BUILDFOR=${SITEINFO_BITS}-bit \ |
| 45 | NO_GLIBC_KEYERR=1 \ |
| 46 | " |
| 47 | |
| 48 | do_install () { |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 49 | oe_runmake DESTDIR=${D} install |
| 50 | } |
| 51 | |
| 52 | do_install_ptest () { |
| 53 | cp -r ${S}/tests ${D}${PTEST_PATH}/ |
| 54 | sed -i -e 's/OSDIST=Unknown/OSDIST=${DISTRO}/' ${D}${PTEST_PATH}/tests/prepare.inc.sh |
| 55 | } |
| 56 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 57 | |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 58 | RDEPENDS:${PN}-ptest += "bash lsb-release make" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 59 | RDEPENDS:${PN}-ptest:append:libc-glibc = " glibc-utils" |
| 60 | RDEPENDS:${PN}-ptest:append:libc-musl = " musl-utils" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 61 | |
| 62 | BBCLASSEXTEND = "native nativesdk" |