William A. Kennington III | 68dc600 | 2024-02-08 16:19:06 -0800 | [diff] [blame] | 1 | require nanopb.inc |
2 | |||||
3 | EXTRA_OECMAKE += " \ | ||||
4 | -Dnanopb_PROTOC_PATH=/bin/false \ | ||||
5 | -DBUILD_SHARED_LIBS=ON \ | ||||
6 | -Dnanopb_BUILD_RUNTIME=ON \ | ||||
7 | -Dnanopb_BUILD_GENERATOR=OFF \ | ||||
8 | " | ||||
9 | |||||
10 | # Maintain compatability with old header locations for packages | ||||
11 | # which haven't yet migrated to `nanopb/pb*.h` | ||||
12 | do_install:append() { | ||||
13 | for hdr in ${D}${includedir}/nanopb/*; do | ||||
14 | ln -sv nanopb/$(basename "$hdr") ${D}${includedir}/ | ||||
15 | done | ||||
16 | } | ||||
17 |