Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "Crypt Openssl RSA cpan module" |
| 2 | SECTION = "libs" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 3 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a67ceecc5d9a91a5a0d003ba50c26346" |
| 5 | |
| 6 | SRC_URI = "http://www.cpan.org/modules/by-module/Crypt/Crypt-OpenSSL-RSA-${PV}.tar.gz \ |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 7 | " |
| 8 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 9 | SRC_URI[sha256sum] = "bdbe630f6d6f540325746ad99977272ac8664ff81bd19f0adaba6d6f45efd864" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 10 | |
| 11 | DEPENDS += "libcrypt-openssl-guess-perl-native openssl" |
| 12 | |
| 13 | RDEPENDS:${PN} = " \ |
| 14 | libcrypt-openssl-random-perl \ |
| 15 | perl-module-autoloader \ |
| 16 | perl-module-carp \ |
| 17 | perl-module-strict \ |
| 18 | perl-module-warnings \ |
| 19 | perl-module-xsloader \ |
| 20 | " |
| 21 | |
| 22 | EXTRA_CPANFLAGS = "INC='-I${STAGING_INCDIR}' LIBS='-L${STAGING_LIBDIR} -lssl -L${STAGING_DIR_TARGET}${base_libdir} -lcrypto'" |
| 23 | |
| 24 | S = "${WORKDIR}/Crypt-OpenSSL-RSA-${PV}" |
| 25 | |
| 26 | inherit cpan ptest-perl |
| 27 | |
| 28 | do_compile() { |
| 29 | export OTHERLDFLAGS='-Wl,-rpath' |
| 30 | cpan_do_compile |
| 31 | } |
| 32 | |
| 33 | RDEPENDS:${PN}-ptest = " \ |
| 34 | ${PN} \ |
| 35 | perl-module-file-copy \ |
| 36 | perl-module-test \ |
| 37 | perl-module-test-more \ |
| 38 | " |