blob: 5969220a41276539140afe48533b6e5f4ec5caa8 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001SUMMARY = "Library for interfacing with common SoC peripherals"
2DESCRIPTION = "libsoc is a C library to interface with common peripherals (gpio, i2c, spi, pwm) \
3 found in SoC (System on Chips) through generic Linux Kernel interfaces."
4
5HOMEPAGE = "https://github.com/jackmitch/libsoc"
6
Andrew Geissler9aee5002022-03-30 16:27:02 +00007LICENSE = "LGPL-2.1-only"
Patrick Williamsddad1a12017-02-23 20:36:32 -06008LIC_FILES_CHKSUM = "file://LICENCE;md5=e0bfebea12a718922225ba987b2126a5"
9
Brad Bishope42b3e32020-01-15 22:08:42 -050010inherit autotools pkgconfig python3-dir
Patrick Williamsddad1a12017-02-23 20:36:32 -060011
12SRCREV = "fd1ad6e7823fa76d8db0d3c5884faffa8ffddafb"
Andrew Geissler595f6302022-01-24 19:11:47 +000013SRC_URI = "git://github.com/jackmitch/libsoc.git;branch=master;protocol=https"
Patrick Williamsddad1a12017-02-23 20:36:32 -060014
15S = "${WORKDIR}/git"
16
17BOARD ??= "devboard"
18
19PACKAGECONFIG ?= ""
20
21PACKAGECONFIG[disabledebug] = "--disable-debug,,"
22PACKAGECONFIG[allboardconfigs] = "--with-board-configs,,"
23PACKAGECONFIG[enableboardconfig] = "--enable-board=${BOARD},,"
Patrick Williams39653562024-03-01 08:54:02 -060024PACKAGECONFIG[python] = "--enable-python=${STAGING_BINDIR_NATIVE}/python3-native/python3,,python3 python3-native"
Patrick Williamsddad1a12017-02-23 20:36:32 -060025
26PACKAGES =+ "${@bb.utils.contains('PACKAGECONFIG', 'python', \
Patrick Williams39653562024-03-01 08:54:02 -060027 'python3-libsoc-staticdev python3-libsoc', '', d)}"
Patrick Williamsddad1a12017-02-23 20:36:32 -060028
Patrick Williams213cb262021-08-07 19:21:33 -050029RDEPENDS:${PN} = "libgcc"
Patrick Williamsddad1a12017-02-23 20:36:32 -060030
Patrick Williams39653562024-03-01 08:54:02 -060031FILES:python3-libsoc-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*/*.a"
32FILES:python3-libsoc += "${PYTHON_SITEPACKAGES_DIR}"