Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 1 | SUMMARY = "Network monitoring tools" |
| 2 | DESCRIPTION = "Utilities for the IP protocol, including traceroute6, \ |
| 3 | tracepath, tracepath6, ping, ping6 and arping." |
| 4 | HOMEPAGE = "https://github.com/iputils/iputils" |
| 5 | SECTION = "console/network" |
| 6 | |
| 7 | LICENSE = "BSD & GPLv2+" |
| 8 | |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=55aa8c9fcad0691cef0ecd420361e390" |
| 10 | |
| 11 | DEPENDS = "gnutls" |
| 12 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | SRC_URI = "git://github.com/iputils/iputils \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | file://0001-rarpd-rdisc-Drop-PrivateUsers.patch \ |
| 15 | " |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame^] | 16 | SRCREV = "23c3782ae0c7f9c6ae59dbed8ad9204f8758542b" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
| 20 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>s\d+)" |
| 21 | |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 22 | # Fixed in 2000-10-10, but the versioning of iputils |
| 23 | # breaks the version order. |
| 24 | CVE_CHECK_WHITELIST += "CVE-2000-1213 CVE-2000-1214" |
| 25 | |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame^] | 26 | PACKAGECONFIG ??= "libcap rarpd \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 27 | ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ninfod traceroute6', '', d)} \ |
| 28 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 29 | PACKAGECONFIG[libcap] = "-DUSE_CAP=true, -DUSE_CAP=false, libcap" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 30 | PACKAGECONFIG[libidn] = "-DUSE_IDN=true, -DUSE_IDN=false, libidn2" |
| 31 | PACKAGECONFIG[gettext] = "-DUSE_GETTEXT=true, -DUSE_GETTEXT=false, gettext" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 32 | PACKAGECONFIG[ninfod] = "-DBUILD_NINFOD=true,-DBUILD_NINFOD=false," |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 33 | PACKAGECONFIG[rarpd] = "-DBUILD_RARPD=true,-DBUILD_RARPD=false," |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 34 | PACKAGECONFIG[systemd] = "-Dsystemdunitdir=${systemd_unitdir}/system,,systemd" |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame^] | 35 | PACKAGECONFIG[tftpd] = "-DBUILD_TFTPD=true, -DBUILD_TFTPD=false," |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 36 | PACKAGECONFIG[traceroute6] = "-DBUILD_TRACEROUTE6=true,-DBUILD_TRACEROUTE6=false," |
| 37 | PACKAGECONFIG[docs] = "-DBUILD_HTML_MANS=true -DBUILD_MANS=true,-DBUILD_HTML_MANS=false -DBUILD_MANS=false, libxslt" |
| 38 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 39 | inherit meson systemd update-alternatives |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 40 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 41 | # Have to disable setcap/suid as its not deterministic |
| 42 | EXTRA_OEMESON += "--prefix=${root_prefix}/ -DNO_SETCAP_OR_SUID=true" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 43 | |
| 44 | ALTERNATIVE_PRIORITY = "100" |
| 45 | |
| 46 | ALTERNATIVE_${PN}-ping = "ping" |
| 47 | ALTERNATIVE_LINK_NAME[ping] = "${base_bindir}/ping" |
| 48 | |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame^] | 49 | SPLITPKGS = "${PN}-ping ${PN}-arping ${PN}-tracepath ${PN}-clockdiff ${PN}-rdisc \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 50 | ${@bb.utils.contains('PACKAGECONFIG', 'rarpd', '${PN}-rarpd', '', d)} \ |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame^] | 51 | ${@bb.utils.contains('PACKAGECONFIG', 'tftpd', '${PN}-tftpd', '', d)} \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 52 | ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', '${PN}-traceroute6 ${PN}-ninfod', '', d)}" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 53 | PACKAGES += "${SPLITPKGS}" |
| 54 | |
| 55 | ALLOW_EMPTY_${PN} = "1" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 56 | RDEPENDS_${PN} += "${SPLITPKGS}" |
| 57 | |
| 58 | FILES_${PN} = "" |
| 59 | FILES_${PN}-ping = "${base_bindir}/ping.${BPN}" |
| 60 | FILES_${PN}-arping = "${base_bindir}/arping" |
| 61 | FILES_${PN}-tracepath = "${base_bindir}/tracepath" |
| 62 | FILES_${PN}-traceroute6 = "${base_bindir}/traceroute6" |
| 63 | FILES_${PN}-clockdiff = "${base_bindir}/clockdiff" |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame^] | 64 | FILES_${PN}-tftpd = "${base_bindir}/tftpd ${sysconfdir}/xinetd.d/tftp" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 65 | FILES_${PN}-rarpd = "${base_sbindir}/rarpd ${systemd_unitdir}/system/rarpd@.service" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 66 | FILES_${PN}-rdisc = "${base_sbindir}/rdisc" |
| 67 | FILES_${PN}-ninfod = "${base_sbindir}/ninfod ${sysconfdir}/init.d/ninfod.sh" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 68 | |
| 69 | SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', '${PN}-ninfod', '', d)} \ |
| 70 | ${PN}-rdisc" |
| 71 | SYSTEMD_SERVICE_${PN}-ninfod = "ninfod.service" |
| 72 | SYSTEMD_SERVICE_${PN}-rdisc = "rdisc.service" |