Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 1 | SUMMARY = "Snowball compiler and stemming algorithms" |
| 2 | HOMEPAGE = "https://snowballstem.org/" |
| 3 | LICENSE = "BSD-3-Clause" |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=19139aaf3c8c8fa1ca6edd59c072fb9f" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 5 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 6 | DEPENDS:class-target = "${BPN}-native" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 7 | |
| 8 | SRC_URI = "\ |
| 9 | git://github.com/snowballstem/snowball.git \ |
| 10 | file://0001-Build-so-lib.patch \ |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 11 | " |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 12 | SRCREV = "4764395431c8f2a0b4fe18b816ab1fc966a45837" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 13 | S = "${WORKDIR}/git" |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 14 | PV = "2.1.0" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 15 | LIBVER = "0.0.0" |
| 16 | |
| 17 | inherit lib_package |
| 18 | |
| 19 | BBCLASSEXTEND = "native" |
| 20 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 21 | do_compile:prepend:class-target() { |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 22 | # use native tools |
| 23 | sed -i 's:./snowball :snowball :g' ${S}/GNUmakefile |
| 24 | } |
| 25 | |
| 26 | do_install() { |
| 27 | install -d ${D}${bindir} |
| 28 | install -m 755 ${S}/snowball ${D}${bindir} |
| 29 | install -m 755 ${S}/stemwords ${D}${bindir} |
| 30 | |
| 31 | install -d ${D}${libdir} |
| 32 | install -m 755 ${S}/libstemmer.so.${LIBVER} ${D}${libdir}/ |
| 33 | ln -s libstemmer.so.${LIBVER} ${D}${libdir}/libstemmer.so.0 |
| 34 | ln -s libstemmer.so.${LIBVER} ${D}${libdir}/libstemmer.so |
| 35 | |
| 36 | install -d ${D}${includedir} |
| 37 | install -m 644 ${S}/include/*.h ${D}${includedir} |
| 38 | } |