Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Tools to generate block map (AKA bmap) and flash images using bmap" |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame] | 2 | DESCRIPTION = "bmaptool - tools to generate block map (AKA bmap) and flash images using \ |
| 3 | bmap. bmaptool is a generic tool for creating the block map (bmap) for a file, \ |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 4 | and copying files using the block map. The idea is that large file containing \ |
| 5 | unused blocks, like raw system image files, can be copied or flashed a lot \ |
| 6 | faster with bmaptool than with traditional tools like "dd" or "cp"." |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame] | 7 | HOMEPAGE = "https://github.com/yoctoproject/bmaptool" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 8 | SECTION = "console/utils" |
| 9 | LICENSE = "GPL-2.0-only" |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 11 | |
Patrick Williams | 56b44a9 | 2024-01-19 08:49:29 -0600 | [diff] [blame] | 12 | FILESEXTRAPATHS:prepend := "${THISDIR}/files:" |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame] | 13 | SRC_URI = "git://github.com/yoctoproject/${BPN};branch=main;protocol=https \ |
Patrick Williams | 56b44a9 | 2024-01-19 08:49:29 -0600 | [diff] [blame] | 14 | file://0001-BmapCopy.py-fix-error-message.patch \ |
| 15 | file://0002-CLI.py-fix-block-device-udev-race-condition.patch \ |
| 16 | file://0003-BmapCopy.py-tweak-suggested-udev-rule.patch \ |
| 17 | " |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 18 | |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 19 | SRCREV = "d84a6fd202fe246a0bc19ed2082e41bcdd75fb13" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 20 | S = "${WORKDIR}/git" |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 21 | BASEVER = "3.7" |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 22 | PV = "${BASEVER}+git" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 23 | |
| 24 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" |
| 25 | |
| 26 | # Need df from coreutils |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 27 | RDEPENDS:${PN} = "python3-core python3-compression python3-misc python3-mmap python3-setuptools python3-fcntl python3-six coreutils" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 28 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 29 | inherit setuptools3 |
| 30 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 31 | BBCLASSEXTEND = "native nativesdk" |