blob: a8e6e563da74d4a886840cfd59de26d4458a709b [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "open-source formatting library for C++"
2DESCRIPTION = "{fmt} is an open-source formatting library for C++. It can be used as a safe and fast alternative to (s)printf and iostreams."
3HOMEPAGE = "https://fmt.dev"
4LICENSE = "MIT"
Patrick Williamse760df82023-05-26 11:10:49 -05005LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=b9257785fc4f3803a4b71b76c1412729"
Andrew Geissler595f6302022-01-24 19:11:47 +00006
7SRC_URI = "git://github.com/fmtlib/fmt;branch=master;protocol=https"
Patrick Williamse760df82023-05-26 11:10:49 -05008SRCREV = "a0b8a92e3d1532361c2f7feb63babc5c18d00ef2"
Andrew Geissler595f6302022-01-24 19:11:47 +00009
10S = "${WORKDIR}/git"
11
12inherit cmake
13inherit ptest
14
15EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON"
16
17BBCLASSEXTEND = "native nativesdk"