Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "open-source formatting library for C++" |
| 2 | DESCRIPTION = "{fmt} is an open-source formatting library for C++. It can be used as a safe and fast alternative to (s)printf and iostreams." |
| 3 | HOMEPAGE = "https://fmt.dev" |
| 4 | LICENSE = "MIT" |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=b9257785fc4f3803a4b71b76c1412729" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 6 | |
| 7 | SRC_URI = "git://github.com/fmtlib/fmt;branch=master;protocol=https" |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 8 | SRCREV = "a0b8a92e3d1532361c2f7feb63babc5c18d00ef2" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 9 | |
| 10 | S = "${WORKDIR}/git" |
| 11 | |
| 12 | inherit cmake |
| 13 | inherit ptest |
| 14 | |
| 15 | EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON" |
| 16 | |
| 17 | BBCLASSEXTEND = "native nativesdk" |