Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | require wireguard.inc |
| 2 | |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 3 | SRCREV = "fe402261666821514377d06c2c68ed9bc19e7634" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 4 | |
| 5 | SRC_URI = "git://git.zx2c4.com/wireguard-linux-compat" |
| 6 | |
| 7 | inherit module kernel-module-split |
| 8 | |
| 9 | DEPENDS = "virtual/kernel libmnl" |
| 10 | |
| 11 | # This module requires Linux 3.10 higher and several networking related |
| 12 | # configuration options. For exact kernel requirements visit: |
| 13 | # https://www.wireguard.io/install/#kernel-requirements |
| 14 | |
| 15 | EXTRA_OEMAKE_append = " \ |
| 16 | KERNELDIR=${STAGING_KERNEL_DIR} \ |
| 17 | " |
| 18 | |
| 19 | MAKE_TARGETS = "module" |
| 20 | |
| 21 | RRECOMMENDS_${PN} = "kernel-module-xt-hashlimit" |
| 22 | MODULE_NAME = "wireguard" |
| 23 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 24 | module_do_install() { |
| 25 | install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME} |
| 26 | install -m 0644 ${MODULE_NAME}.ko \ |
| 27 | ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}/${MODULE_NAME}.ko |
| 28 | } |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 29 | |
| 30 | # WireGuard has been merged into Linux kernel >= 5.6 and therefore this compatibility module is no longer required. |
| 31 | # OE-core post dunfell has moved to use kernel 5.8 which now means we cant build this module in world builds |
| 32 | # for reference machines e.g. qemu |
| 33 | EXCLUDE_FROM_WORLD = "1" |