Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "A top utility for I/O" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 2 | LICENSE = "GPL-2.0-or-later" |
Patrick Williams | da29531 | 2023-12-05 16:48:56 -0600 | [diff] [blame] | 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=72ad44c0841d1e759669d27744e39389" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 4 | |
| 5 | DEPENDS = "ncurses" |
| 6 | |
Patrick Williams | da29531 | 2023-12-05 16:48:56 -0600 | [diff] [blame] | 7 | SRC_URI = "git://github.com/Tomas-M/iotop.git;branch=master;protocol=https" |
| 8 | SRCREV = "9d60bb7e262e0d41b0aa3bcfaa806fa4f42e548a" |
| 9 | |
| 10 | S = "${WORKDIR}/git" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 11 | |
| 12 | inherit pkgconfig |
| 13 | |
| 14 | EXTRA_OEMAKE = "V=1 STRIP=true" |
| 15 | # Fixes llvm-bc70b5.o: can't link soft-float modules with double-float modules |
| 16 | EXTRA_OEMAKE:append:toolchain-clang:riscv64 = " NO_FLTO=1" |
| 17 | EXTRA_OEMAKE:append:toolchain-clang:riscv32 = " NO_FLTO=1" |
| 18 | |
| 19 | # Workaround BFD linker crash with clang on arm |
| 20 | # revisit when upgrading binutils and see if its fixed |
| 21 | LDFLAGS:append:toolchain-clang:arm = " -fuse-ld=lld" |
| 22 | |
| 23 | do_install() { |
| 24 | oe_runmake install DESTDIR=${D} |
| 25 | } |