blob: 8d19c629806dacb6fcfa51456e544bdf323b911e [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "A top utility for I/O"
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "GPL-2.0-or-later"
Patrick Williamsda295312023-12-05 16:48:56 -06003LIC_FILES_CHKSUM = "file://LICENSE;md5=72ad44c0841d1e759669d27744e39389"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00004
5DEPENDS = "ncurses"
6
Patrick Williamsda295312023-12-05 16:48:56 -06007SRC_URI = "git://github.com/Tomas-M/iotop.git;branch=master;protocol=https"
8SRCREV = "9d60bb7e262e0d41b0aa3bcfaa806fa4f42e548a"
9
10S = "${WORKDIR}/git"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000011
12inherit pkgconfig
13
14EXTRA_OEMAKE = "V=1 STRIP=true"
15# Fixes llvm-bc70b5.o: can't link soft-float modules with double-float modules
16EXTRA_OEMAKE:append:toolchain-clang:riscv64 = " NO_FLTO=1"
17EXTRA_OEMAKE:append:toolchain-clang:riscv32 = " NO_FLTO=1"
18
19# Workaround BFD linker crash with clang on arm
20# revisit when upgrading binutils and see if its fixed
21LDFLAGS:append:toolchain-clang:arm = " -fuse-ld=lld"
22
23do_install() {
24 oe_runmake install DESTDIR=${D}
25}