Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "nanomsg socket library" |
| 2 | DESCRIPTION = "nanomsg is a socket library that provides several common \ |
| 3 | communication patterns. It aims to make the networking layer fast, scalable, \ |
| 4 | and easy to use. Implemented in C, it works on a wide range of operating \ |
| 5 | systems with no further dependencies." |
| 6 | HOMEPAGE = "https://nanomsg.org/" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 7 | LICENSE = "MIT" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=587b3fd7fd291e418ff4d2b8f3904755" |
| 9 | |
| 10 | SECTION = "libs/networking" |
| 11 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 12 | SRC_URI = "git://github.com/nanomsg/nanomsg.git;protocol=https;branch=master" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 13 | SRCREV = "a081f1720f576d3e72ddce14e159ba90384e5b92" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | inherit cmake pkgconfig |
| 18 | |
| 19 | # nanomsg documentation generation requires asciidoctor, |
| 20 | # not asciidoc, and currently there's no asciidoctor-native |
| 21 | # recipe anywhere in openembedded-core or meta-openembedded |
| 22 | EXTRA_OECMAKE = " -DNN_ENABLE_DOC=OFF " |
| 23 | |
| 24 | # we don't want nanomsg-tools to be renamed to libnanomsg-tools |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 25 | DEBIAN_NOAUTONAME:${PN}-tools = "1" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 26 | |
| 27 | PACKAGES =+ "${PN}-tools" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 28 | FILES:${PN}-tools = "${bindir}/*" |