Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Provides support for the Tag Image File Format (TIFF)" |
| 2 | DESCRIPTION = "Library provides support for the Tag Image File Format \ |
| 3 | (TIFF), a widely used format for storing image data. This library \ |
| 4 | provide means to easily access and create TIFF image files." |
| 5 | HOMEPAGE = "http://www.libtiff.org/" |
| 6 | LICENSE = "BSD-2-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a3e32d664d6db1386b4689c8121531c3" |
| 8 | |
| 9 | CVE_PRODUCT = "libtiff" |
| 10 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 11 | SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \ |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 12 | file://CVE-2023-6277-At-image-reading-compare-data-size-of-some-tags-data.patch \ |
| 13 | file://CVE-2023-6277-At-image-reading-compare-data-size-of-some-tags-data-2.patch \ |
| 14 | file://CVE-2023-6277-Apply-1-suggestion-s-to-1-file-s.patch \ |
Patrick Williams | f52e3dd | 2024-01-26 13:04:43 -0600 | [diff] [blame] | 15 | file://CVE-2023-6228.patch \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 16 | file://CVE-2023-52355-0001.patch \ |
| 17 | file://CVE-2023-52355-0002.patch \ |
| 18 | file://CVE-2023-52356.patch \ |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 19 | " |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 20 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 21 | SRC_URI[sha256sum] = "88b3979e6d5c7e32b50d7ec72fb15af724f6ab2cbf7e10880c360a77e4b5d99a" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 22 | |
| 23 | # exclude betas |
| 24 | UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar" |
| 25 | |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 26 | CVE_STATUS[CVE-2015-7313] = "fixed-version: Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313 and already 4.3.0 doesn't have the issue" |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 27 | CVE_STATUS[CVE-2023-3164] = "cpe-incorrect: Issue only affects the tiffcrop tool not compiled by default since 4.6.0" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 28 | |
| 29 | inherit autotools multilib_header |
| 30 | |
| 31 | CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no" |
| 32 | |
| 33 | PACKAGECONFIG ?= "cxx jpeg zlib lzma \ |
| 34 | strip-chopping extrasample-as-alpha check-ycbcr-subsampling" |
| 35 | |
| 36 | PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,," |
| 37 | PACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig," |
| 38 | PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg," |
| 39 | PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib," |
| 40 | PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz," |
| 41 | PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp," |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 42 | PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd," |
| 43 | PACKAGECONFIG[libdeflate] = "--enable-libdeflate,--disable-libdeflate,libdeflate," |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 44 | |
| 45 | # Convert single-strip uncompressed images to multiple strips of specified |
| 46 | # size (default: 8192) to reduce memory usage |
| 47 | PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,," |
| 48 | |
| 49 | # Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA |
| 50 | PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,," |
| 51 | |
| 52 | # Control picking up YCbCr subsample info. Disable to support files lacking |
| 53 | # the tag |
| 54 | PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,," |
| 55 | |
| 56 | # Support a mechanism allowing reading large strips (usually one strip files) |
| 57 | # in chunks when using TIFFReadScanline. Experimental 4.0+ feature |
| 58 | PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,," |
| 59 | |
| 60 | PACKAGES =+ "tiffxx tiff-utils" |
| 61 | FILES:tiffxx = "${libdir}/libtiffxx.so.*" |
| 62 | FILES:tiff-utils = "${bindir}/*" |
| 63 | |
| 64 | do_install:append() { |
| 65 | oe_multilib_header tiffconf.h |
| 66 | } |
| 67 | |
| 68 | BBCLASSEXTEND = "native nativesdk" |