blob: 78949f7a4cfc7d49a29782b099f26d9268c91e57 [file] [log] [blame]
Brad Bishop3077a7f2017-01-12 21:44:51 -05001SUMMARY = "OpenBMC - Applications"
Brad Bishop93fb5352015-09-09 03:59:20 +00002PR = "r1"
3
4inherit packagegroup
Brad Bishop93fb5352015-09-09 03:59:20 +00005
Brad Bishop93fb5352015-09-09 03:59:20 +00006PROVIDES = "${PACKAGES}"
7PACKAGES = " \
Brad Bishopdb32a7c2017-03-01 16:16:06 -05008 ${PN}-bmc-state-mgmt \
Brad Bishopb52116a2020-08-10 20:45:15 -04009 ${PN}-bmcweb \
Brad Bishopdb32a7c2017-03-01 16:16:06 -050010 ${PN}-chassis-state-mgmt \
Brad Bishop8c09b142020-08-11 08:20:31 -040011 ${PN}-console \
Brad Bishopb52116a2020-08-10 20:45:15 -040012 ${PN}-dbus-monitor \
Brad Bishopa2429372016-09-06 22:44:21 -040013 ${PN}-extras \
Brad Bishope3fe5782020-08-10 20:20:47 -040014 ${PN}-devtools \
Brad Bishop4824d4c2017-05-01 11:54:34 -040015 ${PN}-fan-control \
Vijay Khemkad549dee2020-09-08 11:56:19 -070016 ${PN}-health-monitor \
Brad Bishopdb32a7c2017-03-01 16:16:06 -050017 ${PN}-host-state-mgmt \
Brad Bishopb52116a2020-08-10 20:45:15 -040018 ${PN}-ikvm \
Brad Bishop4f12f722017-02-01 21:04:14 -050019 ${PN}-inventory \
20 ${PN}-leds \
Brad Bishopeca8d7c2018-03-23 13:07:46 -040021 ${PN}-logging \
Brad Bishop0f1b05d2018-10-16 11:02:54 -050022 ${PN}-remote-logging \
Brad Bishop8c09b142020-08-11 08:20:31 -040023 ${PN}-rng \
Brad Bishop4f12f722017-02-01 21:04:14 -050024 ${PN}-sensors \
Gunnar Mills058788a2017-02-15 16:01:45 -060025 ${PN}-software \
Andrew Geisslerb1afecc2017-05-08 15:58:01 -050026 ${PN}-host-check-mgmt \
Jayanth Othayoth9be81b12017-05-08 09:25:05 -050027 ${PN}-debug-collector \
Deepak Kodihallifeb88672017-05-17 06:42:51 -050028 ${PN}-settings \
Ratan Guptad3c61642017-07-06 21:09:14 +053029 ${PN}-network \
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +053030 ${PN}-user-mgmt \
Brad Bishopb52116a2020-08-10 20:45:15 -040031 ${PN}-user-mgmt-ldap \
Brad Bishop93fb5352015-09-09 03:59:20 +000032 "
33
Brad Bishopdb32a7c2017-03-01 16:16:06 -050034SUMMARY_${PN}-bmc-state-mgmt = "BMC state management"
35RDEPENDS_${PN}-bmc-state-mgmt = " \
36 ${VIRTUAL-RUNTIME_obmc-bmc-state-manager} \
Andrew Geissler2138fde2019-08-14 10:01:10 -050037 phosphor-state-manager-systemd-target-monitor \
Brad Bishopdb32a7c2017-03-01 16:16:06 -050038 "
39
Brad Bishopb52116a2020-08-10 20:45:15 -040040SUMMARY_${PN}-bmcweb = "bmcweb support"
41RDEPENDS_${PN}-bmcweb = " \
42 bmcweb \
43 phosphor-bmcweb-cert-config \
44 "
45
Brad Bishopdb32a7c2017-03-01 16:16:06 -050046SUMMARY_${PN}-chassis-state-mgmt = "Chassis state management"
47RDEPENDS_${PN}-chassis-state-mgmt = " \
48 ${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \
Anthony Wilsoncd800c82019-03-30 08:11:32 -070049 obmc-phosphor-power \
Brad Bishopdb32a7c2017-03-01 16:16:06 -050050 "
51
Brad Bishop8c09b142020-08-11 08:20:31 -040052SUMMARY_${PN}-console = "Serial over LAN support"
53RDEPENDS_${PN}-console = " \
54 obmc-console \
55 "
56
Brad Bishopb52116a2020-08-10 20:45:15 -040057# Deprecated - add new packages to an existing packagegroup or create a new one.
Brad Bishopa2429372016-09-06 22:44:21 -040058SUMMARY_${PN}-extras = "Extra features"
Brad Bishopb52116a2020-08-10 20:45:15 -040059RDEPENDS_${PN}-extras = ""
Brad Bishop70436da2015-09-16 14:49:27 -040060
Brad Bishope3fe5782020-08-10 20:20:47 -040061SUMMARY_${PN}-devtools = "Development tools"
62RDEPENDS_${PN}-devtools = " \
63 bash \
Brad Bishop8c09b142020-08-11 08:20:31 -040064 ffdc \
Brad Bishope3fe5782020-08-10 20:20:47 -040065 i2c-tools \
James Feist3acedc52019-05-30 11:58:40 -070066 libgpiod-tools \
Brad Bishope3fe5782020-08-10 20:20:47 -040067 lrzsz \
68 rsync \
Adriana Kobylak6adca3a2017-11-09 10:39:02 -060069 "
70
Brad Bishopb52116a2020-08-10 20:45:15 -040071SUMMARY_${PN}-dbus-monitor = "Support for dbus monitoring"
72RDEPENDS_${PN}-dbus-monitor = " \
73 phosphor-dbus-monitor \
74 "
75
Brad Bishop4824d4c2017-05-01 11:54:34 -040076# Use the fan control package group for applications
77# implementing fan control or system fan policy only.
78# Applications that create inventory or sensors should
79# be added those respective package groups instead.
80SUMMARY_${PN}-fan-control = "Fan control"
81RDEPENDS_${PN}-fan-control = " \
Matt Spinlerc133ec12017-04-19 08:23:50 -050082 ${VIRTUAL-RUNTIME_obmc-fan-control} \
Matt Spinlerdd7a0802017-05-01 14:29:20 -050083 phosphor-fan-monitor \
Brad Bishop4824d4c2017-05-01 11:54:34 -040084 "
85
Vijay Khemkad549dee2020-09-08 11:56:19 -070086SUMMARY_${PN}-health-monitor = "Support for health monitoring"
87RDEPENDS_${PN}-health-monitor = " \
88 phosphor-health-monitor \
89 "
90
Brad Bishopdb32a7c2017-03-01 16:16:06 -050091SUMMARY_${PN}-host-state-mgmt = "Host state management"
92RDEPENDS_${PN}-host-state-mgmt = " \
93 ${VIRTUAL-RUNTIME_obmc-host-state-manager} \
Michael Tritzb3b58992017-03-31 12:04:32 -050094 ${VIRTUAL-RUNTIME_obmc-discover-system-state} \
Brad Bishopdb32a7c2017-03-01 16:16:06 -050095 "
96
Brad Bishopb52116a2020-08-10 20:45:15 -040097SUMMARY_${PN}-ikvm = "KVM over IP support"
98RDEPENDS_${PN}-ikvm = " \
99 obmc-ikvm \
100 "
101
Brad Bishop4f12f722017-02-01 21:04:14 -0500102SUMMARY_${PN}-inventory = "Inventory applications"
103RDEPENDS_${PN}-inventory = " \
104 ${VIRTUAL-RUNTIME_obmc-inventory-manager} \
Matthew Barthacd9fe42017-02-24 13:14:43 -0600105 ${VIRTUAL-RUNTIME_obmc-fan-presence} \
Brad Bishop4f12f722017-02-01 21:04:14 -0500106 "
107
108SUMMARY_${PN}-leds = "LED applications"
109RDEPENDS_${PN}-leds = " \
Brad Bishopaf7d0602017-02-27 11:59:49 -0500110 ${VIRTUAL-RUNTIME_obmc-leds-manager} \
111 ${VIRTUAL-RUNTIME_obmc-leds-sysfs} \
Dhruvaraj Subhashchandran6a1b0fc2017-04-27 05:29:56 -0500112 ${VIRTUAL-RUNTIME_obmc-led-monitor} \
Brad Bishop4f12f722017-02-01 21:04:14 -0500113 "
114
Brad Bishopeca8d7c2018-03-23 13:07:46 -0400115SUMMARY_${PN}-logging = "Logging applications"
116RDEPENDS_${PN}-logging = " \
117 phosphor-logging \
Brad Bishop0f1b05d2018-10-16 11:02:54 -0500118 "
119
120SUMMARY_${PN}-remote-logging = "Remote logging applications"
121RDEPENDS_${PN}-remote-logging = " \
Deepak Kodihallif9e9cc62018-08-21 06:40:53 -0500122 rsyslog \
Deepak Kodihalli04aa22f2018-08-28 11:39:41 -0500123 phosphor-rsyslog-config \
Brad Bishopeca8d7c2018-03-23 13:07:46 -0400124 "
125
Brad Bishop8c09b142020-08-11 08:20:31 -0400126SUMMARY_${PN}-rng = "Random Number Generator support"
127RDEPENDS_${PN}-rng = " \
128 rng-tools \
129 "
130
Brad Bishop4f12f722017-02-01 21:04:14 -0500131SUMMARY_${PN}-sensors = "Sensor applications"
132RDEPENDS_${PN}-sensors = " \
133 ${VIRTUAL-RUNTIME_obmc-sensors-hwmon} \
134 "
Gunnar Mills058788a2017-02-15 16:01:45 -0600135
Lei YU4de51f02019-05-06 14:35:27 +0800136${PN}-software-extras = ""
Brad Bishop8623bbe2018-03-09 00:04:00 -0500137
Eddie Jamesb2b7ff62018-02-09 11:59:18 -0600138${PN}-software-extras_df-obmc-ubi-fs = " \
Adriana Kobylakc763ceb2018-06-04 13:06:52 -0500139 phosphor-software-manager-updater-ubi \
Eddie Jamesb2b7ff62018-02-09 11:59:18 -0600140 "
Brad Bishop8623bbe2018-03-09 00:04:00 -0500141
Adriana Kobylak88ec2af2020-06-04 14:03:03 -0500142${PN}-software-extras_df-phosphor-mmc = " \
143 phosphor-software-manager-updater-mmc \
144 "
145
Gunnar Mills058788a2017-02-15 16:01:45 -0600146SUMMARY_${PN}-software = "Software applications"
147RDEPENDS_${PN}-software = " \
Deepak Kodihallib74ceea2017-04-13 23:23:42 -0500148 ${VIRTUAL-RUNTIME_obmc-bmc-download-mgr} \
Gunnar Millscfe00842017-05-15 15:40:58 -0500149 ${VIRTUAL-RUNTIME_obmc-bmc-updater} \
Andrew Geisslera30470f2018-02-09 12:50:57 -0800150 ${VIRTUAL-RUNTIME_obmc-bmc-version} \
Brad Bishop8623bbe2018-03-09 00:04:00 -0500151 ${${PN}-software-extras} \
Andrew Geisslera30470f2018-02-09 12:50:57 -0800152 "
153
Jayanth Othayoth9be81b12017-05-08 09:25:05 -0500154SUMMARY_${PN}-debug-collector = "BMC debug collector"
155RDEPENDS_${PN}-debug-collector = " \
Jayanth Othayoth2a5d91e2017-05-31 06:25:55 -0500156 ${VIRTUAL-RUNTIME_obmc-dump-manager} \
157 ${VIRTUAL-RUNTIME_obmc-dump-monitor} \
Jayanth Othayothf4e66072017-07-29 22:28:44 -0500158 phosphor-debug-collector-dreport \
Marri Devender Raob6e5cb02017-10-11 02:22:46 -0500159 phosphor-debug-collector-scripts \
Vishwanatha Subbannadfd5bf32017-05-12 23:31:55 +0530160 "
Deepak Kodihallifeb88672017-05-17 06:42:51 -0500161
162SUMMARY_${PN}-settings = "Settings applications"
163RDEPENDS_${PN}-settings = " \
Brad Bishop8ad1c1f2020-03-19 16:14:54 -0400164 phosphor-settings-manager \
Deepak Kodihallifeb88672017-05-17 06:42:51 -0500165 "
Ratan Guptad3c61642017-07-06 21:09:14 +0530166
167SUMMARY_${PN}-network = "BMC Network Manager"
168RDEPENDS_${PN}-network = " \
169 ${VIRTUAL-RUNTIME_obmc-network-manager} \
170 "
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +0530171
172SUMMARY_${PN}-user-mgmt = "User management applications"
173RDEPENDS_${PN}-user-mgmt = " \
174 ${VIRTUAL-RUNTIME_obmc-user-mgmt} \
175 "
Brad Bishop8c09b142020-08-11 08:20:31 -0400176RRECOMMENDS_${PN}-user-mgmt = " \
177 pam-plugin-access \
178 "
Brad Bishopb52116a2020-08-10 20:45:15 -0400179
180SUMMARY_${PN}-user-mgmt-ldap = "LDAP users and groups support"
181RDEPENDS_${PN}-user-mgmt-ldap = " \
182 ${PN}-user-mgmt \
183 nss-pam-ldapd \
184 phosphor-ldap \
185 phosphor-nslcd-cert-config \
186 phosphor-nslcd-authority-cert-config \
187 "