blob: ad85576dcbcf8c288159585618c2ba6b387029df [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "HTTP/2 C Library and tools"
2HOMEPAGE = "https://nghttp2.org/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=764abdf30b2eadd37ce47dcbce0ea1ec"
6
Patrick Williamsb58112e2024-03-07 11:16:36 -06007SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/nghttp2-${PV}.tar.xz"
Patrick Williams44b3caf2024-04-12 16:51:14 -05008SRC_URI[sha256sum] = "c0e660175b9dc429f11d25b9507a834fb752eea9135ab420bb7cb7e9dbcc9654"
Andrew Geissler517393d2023-01-13 08:55:19 -06009
10inherit cmake manpages python3native github-releases
11PACKAGECONFIG[manpages] = ""
12
13# examples are never installed, and don't need to be built in the
14# first place
Patrick Williams864cc432023-02-09 14:54:44 -060015EXTRA_OECMAKE = "-DENABLE_EXAMPLES=OFF -DENABLE_APP=OFF -DENABLE_HPACK_TOOLS=OFF -DENABLE_PYTHON_BINDINGS=OFF"
Andrew Geissler517393d2023-01-13 08:55:19 -060016
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060017PACKAGES =+ "lib${BPN} ${PN}-proxy "
Andrew Geissler517393d2023-01-13 08:55:19 -060018
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060019RDEPENDS:${PN} = "${PN}-proxy (>= ${PV})"
Andrew Geissler517393d2023-01-13 08:55:19 -060020RDEPENDS:${PN}:class-native = ""
21RDEPENDS:${PN}-proxy = "openssl python3-core python3-io python3-shell"
22
23ALLOW_EMPTY:${PN} = "1"
24FILES:${PN} = ""
25FILES:lib${BPN} = "${libdir}/*${SOLIBS}"
Andrew Geissler517393d2023-01-13 08:55:19 -060026FILES:${PN}-proxy = "${bindir}/nghttpx ${datadir}/${BPN}/fetch-ocsp-response"
Andrew Geissler517393d2023-01-13 08:55:19 -060027
28BBCLASSEXTEND = "native nativesdk"