Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "C++ framework for json-rpc 1.0 and 2.0" |
| 2 | DESCRIPTION = "JsonRpc-Cpp is an OpenSource implementation of JSON-RPC \ |
| 3 | protocol in C++. JSON-RPC is a lightweight remote procedure \ |
| 4 | call protocol similar to XML-RPC." |
| 5 | HOMEPAGE = "https://github.com/cinemast/libjson-rpc-cpp" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4e728c5b36018f6c383b4b9efd9c8840" |
| 8 | SECTION = "libs" |
Brad Bishop | 7e36d53 | 2019-09-16 07:44:26 -0400 | [diff] [blame] | 9 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 10 | DEPENDS = "curl jsoncpp libmicrohttpd hiredis" |
| 11 | |
Brad Bishop | 7e36d53 | 2019-09-16 07:44:26 -0400 | [diff] [blame] | 12 | SRC_URI = "git://github.com/cinemast/libjson-rpc-cpp" |
| 13 | SRCREV = "4ed5b00dcc409405a19e6d8c6478f703153430e1" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
Brad Bishop | 00ab237 | 2019-10-14 11:06:18 -0400 | [diff] [blame] | 17 | PACKAGECONFIG ?= "" |
| 18 | PACKAGECONFIG[coverage] = "-DWITH_COVERAGE=YES,-DWITH_COVERAGE=NO,," |
| 19 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 20 | inherit cmake |
| 21 | |
| 22 | EXTRA_OECMAKE += "-DCOMPILE_TESTS=NO -DCOMPILE_STUBGEN=NO -DCOMPILE_EXAMPLES=NO \ |
| 23 | -DBUILD_SHARED_LIBS=YES -DBUILD_STATIC_LIBS=YES \ |
| 24 | -DCMAKE_LIBRARY_PATH=${libdir} \ |
| 25 | " |
| 26 | |
| 27 | FILES_${PN}-dev += "${libdir}/libjson-rpc-cpp/cmake" |