Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Python GObject bindings" |
| 2 | HOMEPAGE = "http://www.pygtk.org/" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "LGPLv2.1" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7" |
| 6 | |
Andrew Geissler | 1548c07 | 2019-02-22 16:03:50 -0600 | [diff] [blame] | 7 | inherit gnomebase gobject-introspection distutils-base upstream-version-is-even |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 8 | |
Andrew Geissler | 1548c07 | 2019-02-22 16:03:50 -0600 | [diff] [blame] | 9 | DEPENDS += "python glib-2.0" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 10 | |
Andrew Geissler | 1548c07 | 2019-02-22 16:03:50 -0600 | [diff] [blame] | 11 | SRCNAME = "pygobject" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 12 | SRC_URI = " \ |
| 13 | http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | " |
| 15 | |
| 16 | SRC_URI[md5sum] = "3bac63c86bb963aa401f97859464aa90" |
| 17 | SRC_URI[sha256sum] = "3dd3e21015d06e00482ea665fc1733b77e754a6ab656a5db5d7f7bfaf31ad0b0" |
| 18 | |
| 19 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 20 | |
| 21 | BBCLASSEXTEND = "native" |
| 22 | |
Andrew Geissler | 1548c07 | 2019-02-22 16:03:50 -0600 | [diff] [blame] | 23 | EXTRA_OECONF = "--disable-cairo" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 24 | |
| 25 | RDEPENDS_${PN} += "python-setuptools" |
| 26 | RDEPENDS_${PN}_class-native = "" |
| 27 | |
| 28 | do_install_append() { |
| 29 | # Remove files that clash with python3-pygobject; their content is same |
Andrew Geissler | 1548c07 | 2019-02-22 16:03:50 -0600 | [diff] [blame] | 30 | rm -r ${D}${includedir}/pygobject-3.0/pygobject.h ${D}${libdir}/pkgconfig |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 31 | } |