Joel Stanley | 7259c7d | 2019-11-04 23:43:51 +1030 | [diff] [blame] | 1 | SUMMARY = "eCMD" |
| 2 | DESCRIPTION = "eCMD is a hardware access API for IBM Systems" |
| 3 | LICENSE= "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${S}/NOTICE;md5=fee220301a2af3faf8f211524b4248ea" |
| 5 | |
| 6 | SRC_URI = "git://github.com/open-power/eCMD.git" |
Andrew Geissler | cdd05fa | 2021-05-11 14:27:41 -0500 | [diff] [blame] | 7 | SRCREV = "57b40102a54dac8b4b9cdc91beefd709d222867e" |
Brad Bishop | b3fceb3 | 2020-01-17 11:14:37 -0500 | [diff] [blame] | 8 | DEPENDS += "zlib" |
Joel Stanley | 7259c7d | 2019-11-04 23:43:51 +1030 | [diff] [blame] | 9 | |
Joel Stanley | 5f2105b | 2019-11-05 11:25:16 +1030 | [diff] [blame] | 10 | SRC_URI += "file://croserver.service" |
| 11 | |
Joel Stanley | 7259c7d | 2019-11-04 23:43:51 +1030 | [diff] [blame] | 12 | S = "${WORKDIR}/git" |
| 13 | |
Patrick Williams | 037f7bd | 2020-04-01 17:15:38 -0500 | [diff] [blame] | 14 | inherit python3native |
Andrew Geissler | 1878d70 | 2020-04-28 15:09:18 -0500 | [diff] [blame] | 15 | DEPENDS += "${PYTHON_PN}-distro-native" |
Brad Bishop | b3fceb3 | 2020-01-17 11:14:37 -0500 | [diff] [blame] | 16 | |
Joel Stanley | 7259c7d | 2019-11-04 23:43:51 +1030 | [diff] [blame] | 17 | do_configure() { |
Patrick Williams | 037f7bd | 2020-04-01 17:15:38 -0500 | [diff] [blame] | 18 | LD="${CXX}" ${PYTHON} ${S}/config.py \ |
| 19 | --without-swig --output-root ${B} --target obj \ |
| 20 | --extensions "cmd cip" --build-verbose |
Joel Stanley | 7259c7d | 2019-11-04 23:43:51 +1030 | [diff] [blame] | 21 | } |
| 22 | |
| 23 | do_compile() { |
| 24 | cd ${S}/dllNetwork/server |
| 25 | oe_runmake |
| 26 | } |
| 27 | |
| 28 | do_install() { |
| 29 | install -d ${D}${bindir} |
| 30 | install -m 0755 out_obj/lib/server1p ${D}${bindir}/croserver |
Joel Stanley | 5f2105b | 2019-11-05 11:25:16 +1030 | [diff] [blame] | 31 | |
| 32 | install -d ${D}${systemd_system_unitdir} |
| 33 | install -m 0644 ${WORKDIR}/croserver.service ${D}${systemd_system_unitdir}/ |
Joel Stanley | 7259c7d | 2019-11-04 23:43:51 +1030 | [diff] [blame] | 34 | } |
Joel Stanley | 5f2105b | 2019-11-05 11:25:16 +1030 | [diff] [blame] | 35 | |
| 36 | FILES_${PN} += "${systemd_system_unitdir}/croserver.service" |