Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Network benchmark tool" |
| 2 | DESCRIPTION = "\ |
| 3 | iperf is a tool for active measurements of the maximum achievable bandwidth \ |
| 4 | on IP networks. It supports tuning of various parameters related to timing, \ |
| 5 | protocols, and buffers. For each test it reports the bandwidth, loss, and \ |
| 6 | other parameters." |
| 7 | |
| 8 | HOMEPAGE = "http://software.es.net/iperf/" |
| 9 | SECTION = "console/network" |
| 10 | BUGTRACKER = "https://github.com/esnet/iperf/issues" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 11 | |
| 12 | LICENSE = "BSD-3-Clause" |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 13 | LIC_FILES_CHKSUM = "file://LICENSE;md5=dc6301c8256ceb8f71c9e3c2ae9096b9" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 14 | |
| 15 | SRC_URI = "git://github.com/esnet/iperf.git;branch=master;protocol=https \ |
| 16 | file://0002-Remove-pg-from-profile_CFLAGS.patch \ |
| 17 | file://0001-configure.ac-check-for-CPP-prog.patch \ |
| 18 | " |
| 19 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 20 | SRCREV = "a0be85934144bc04712a6695b14ea6e45c379e1d" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 21 | |
| 22 | S = "${WORKDIR}/git" |
| 23 | |
| 24 | inherit autotools |
| 25 | |
| 26 | PACKAGECONFIG ?= "openssl" |
| 27 | |
| 28 | PACKAGECONFIG[lksctp] = "ac_cv_header_netinet_sctp_h=yes,ac_cv_header_netinet_sctp_h=no,lksctp-tools" |
| 29 | PACKAGECONFIG[openssl] = "--with-openssl=${RECIPE_SYSROOT}${prefix},--without-openssl,openssl" |
| 30 | |
| 31 | CFLAGS += "-D_GNU_SOURCE" |