Joel Stanley | 88aae3e | 2018-05-11 15:16:32 +0930 | [diff] [blame] | 1 | SUMMARY = "OpenPower Hostboot Boot settings tool" |
| 2 | PR = "r1" |
Brad Bishop | 2879d32 | 2018-11-07 14:45:23 -0500 | [diff] [blame] | 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${OPENPOWERBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658" |
Joel Stanley | 88aae3e | 2018-05-11 15:16:32 +0930 | [diff] [blame] | 5 | |
Joel Stanley | 88aae3e | 2018-05-11 15:16:32 +0930 | [diff] [blame] | 6 | inherit obmc-phosphor-systemd |
| 7 | inherit allarch |
| 8 | |
| 9 | SRC_URI = "file://hb_settings" |
| 10 | SYSTEMD_SERVICE_${PN} += "hostboot-settings.service" |
| 11 | |
| 12 | do_fetch[noexec] = "1" |
| 13 | do_patch[noexec] = "1" |
| 14 | do_configure[noexec] = "1" |
| 15 | do_compile[noexec] = "1" |
| 16 | |
| 17 | do_install() { |
| 18 | install -d ${D}${bindir} |
| 19 | install -m 0755 ${WORKDIR}/hb_settings ${D}${bindir} |
| 20 | } |