Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Custom Matchbox session files for the Sato environment" |
| 2 | HOMEPAGE = "http://www.matchbox-project.org/" |
| 3 | BUGTRACKER = "http://bugzilla.yoctoproject.org/" |
| 4 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 5 | LICENSE = "GPL-2.0-or-later" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://session;endline=3;md5=f8a5c5b9c279e52dc094d10e11c2be63" |
| 7 | |
| 8 | SECTION = "x11" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 9 | RDEPENDS:${PN} = "formfactor matchbox-theme-sato matchbox-panel-2 matchbox-desktop matchbox-session gconf" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 10 | |
| 11 | # This package is architecture specific because the session script is modified |
| 12 | # based on the machine architecture. |
| 13 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 14 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 15 | inherit features_check |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 16 | |
| 17 | # The matchbox-theme-sato requires x11 in DISTRO_FEATURES |
| 18 | REQUIRED_DISTRO_FEATURES = "x11" |
| 19 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 20 | SRC_URI = "file://session \ |
| 21 | file://index.theme" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 22 | S = "${WORKDIR}" |
| 23 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 24 | FILES:${PN} += "${datadir}/themes/Sato/index.theme" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 25 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 26 | do_install() { |
| 27 | # This is the set of machine features that the script has markers for |
Patrick Williams | 520786c | 2023-06-25 16:20:36 -0500 | [diff] [blame] | 28 | FEATURES="acpi phone" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 29 | SCRIPT="${S}/sedder" |
| 30 | rm -f $SCRIPT |
| 31 | touch $SCRIPT |
| 32 | for FEAT in $FEATURES; do |
| 33 | if echo ${MACHINE_FEATURES} | awk "/$FEAT/ {exit 1}"; then |
| 34 | echo "/feature-$FEAT/d" >> $SCRIPT |
| 35 | fi |
| 36 | done |
| 37 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 38 | install -D ${S}/index.theme ${D}/${datadir}/themes/Sato/index.theme |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 39 | install -d ${D}/${sysconfdir}/matchbox |
| 40 | sed -f "$SCRIPT" ${S}/session > ${D}/${sysconfdir}/matchbox/session |
| 41 | chmod +x ${D}/${sysconfdir}/matchbox/session |
| 42 | } |
| 43 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 44 | PACKAGE_WRITE_DEPS += "gconf-native" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 45 | pkg_postinst:${PN} () { |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 46 | set_value() { |
| 47 | #type, name, value |
| 48 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type $1 --set /desktop/poky/interface/$2 "$3" |
| 49 | } |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 50 | set_value string theme Adwaita |
| 51 | set_value string matchbox_theme Sato |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 52 | set_value string icon_theme Sato |
| 53 | set_value bool touchscreen true |
| 54 | set_value string font_name "Sans 9" |
| 55 | } |