blob: 9bbd7d51c8314c45407c1fa9984113867915dde6 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Tools to generate block map (AKA bmap) and flash images using bmap"
2DESCRIPTION = "Bmap-tools - tools to generate block map (AKA bmap) and flash images using \
3bmap. Bmaptool is a generic tool for creating the block map (bmap) for a file, \
4and copying files using the block map. The idea is that large file containing \
5unused blocks, like raw system image files, can be copied or flashed a lot \
6faster with bmaptool than with traditional tools like "dd" or "cp"."
7HOMEPAGE = "https://github.com/01org/bmap-tools"
8SECTION = "console/utils"
9LICENSE = "GPL-2.0-only"
Patrick Williams169d7bc2024-01-05 11:33:25 -060010LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000011
Patrick Williams56b44a92024-01-19 08:49:29 -060012FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
13SRC_URI = "git://github.com/intel/${BPN};branch=main;protocol=https \
14 file://0001-BmapCopy.py-fix-error-message.patch \
15 file://0002-CLI.py-fix-block-device-udev-race-condition.patch \
16 file://0003-BmapCopy.py-tweak-suggested-udev-rule.patch \
17 "
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000018
Patrick Williams169d7bc2024-01-05 11:33:25 -060019SRCREV = "d84a6fd202fe246a0bc19ed2082e41bcdd75fb13"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000020S = "${WORKDIR}/git"
Patrick Williams169d7bc2024-01-05 11:33:25 -060021BASEVER = "3.7"
Andrew Geissler5082cc72023-09-11 08:41:39 -040022PV = "${BASEVER}+git"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000023
24UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
25
26# Need df from coreutils
27RDEPENDS:${PN} = "python3-core python3-compression python3-mmap python3-setuptools python3-fcntl python3-six coreutils"
28
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000029inherit setuptools3
30
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000031BBCLASSEXTEND = "native nativesdk"