blob: 0ee635c0dcfa33d5de0e52df6fda566b06be3fd0 [file] [log] [blame]
Matt Spinlereea390f2017-08-14 13:27:09 -05001SUMMARY = "Copy error yaml files to known path for elog parsing"
2PR = "r1"
3
4inherit native
5inherit obmc-phosphor-license
6inherit phosphor-dbus-yaml
7
8PROVIDES += "witherspoon-pfault-analysis-error-native"
9require witherspoon-pfault-analysis.inc
10
11S = "${WORKDIR}/git"
12
13do_install_append() {
14 SRC=${S}/xyz/openbmc_project/Power
15 DEST=${yaml_dir}/xyz/openbmc_project/Power
16 install -d ${DEST}
17 install ${SRC}/Fault.errors.yaml ${DEST}
Matt Spinler0464f532017-09-19 14:02:40 -050018 install ${SRC}/Fault.metadata.yaml ${DEST}
Matt Spinlereea390f2017-08-14 13:27:09 -050019}