Brad Bishop | 6e05ef2 | 2020-04-22 14:06:02 -0400 | [diff] [blame] | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:" |
| 2 | |
Brad Bishop | 6e05ef2 | 2020-04-22 14:06:02 -0400 | [diff] [blame] | 3 | PACKAGECONFIG_append_rainier = " host-dump-offload-pldm" |
| 4 | PACKAGECONFIG_append_witherspoon-tacoma = " host-dump-offload-pldm" |
Matt Spinler | 036c8f9 | 2018-03-29 16:34:38 -0500 | [diff] [blame] | 5 | |
| 6 | SRC_URI += "file://plugins.d/ibm_elogall" |
Matt Spinler | 1a247b7 | 2020-07-27 16:30:21 -0500 | [diff] [blame^] | 7 | SRC_URI += "file://plugins.d/pels" |
Matt Spinler | 036c8f9 | 2018-03-29 16:34:38 -0500 | [diff] [blame] | 8 | |
| 9 | install_ibm_plugins() { |
| 10 | |
| 11 | install -m 0755 ${WORKDIR}/plugins.d/ibm_elogall ${D}${dreport_plugin_dir} |
Matt Spinler | 1a247b7 | 2020-07-27 16:30:21 -0500 | [diff] [blame^] | 12 | install -m 0755 ${WORKDIR}/plugins.d/pels ${D}${dreport_plugin_dir} |
Matt Spinler | 036c8f9 | 2018-03-29 16:34:38 -0500 | [diff] [blame] | 13 | |
| 14 | } |
| 15 | |
| 16 | #Link in the plugins so dreport run them at the appropriate time |
| 17 | python link_ibm_plugins() { |
| 18 | |
| 19 | workdir = d.getVar('WORKDIR', True) |
| 20 | script = os.path.join(workdir, 'plugins.d', 'ibm_elogall') |
| 21 | install_dreport_user_script(script, d) |
Matt Spinler | 1a247b7 | 2020-07-27 16:30:21 -0500 | [diff] [blame^] | 22 | |
| 23 | script = os.path.join(workdir, 'plugins.d', 'pels') |
| 24 | install_dreport_user_script(script, d) |
Matt Spinler | 036c8f9 | 2018-03-29 16:34:38 -0500 | [diff] [blame] | 25 | } |
| 26 | |
| 27 | do_install[postfuncs] += "install_ibm_plugins" |
| 28 | do_install[postfuncs] += "link_ibm_plugins" |