Brad Bishop | 6eb25f4 | 2017-01-28 13:00:52 -0500 | [diff] [blame] | 1 | SUMMARY = "Palmetto IPMI to DBus Inventory mapping." |
| 2 | PR = "r1" |
Patrick Venture | 1fccb1b | 2018-11-05 20:27:48 -0800 | [diff] [blame] | 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658" |
Brad Bishop | 6eb25f4 | 2017-01-28 13:00:52 -0500 | [diff] [blame] | 5 | |
| 6 | inherit native |
Brad Bishop | 6eb25f4 | 2017-01-28 13:00:52 -0500 | [diff] [blame] | 7 | inherit phosphor-ipmi-fru |
| 8 | |
| 9 | SRC_URI += "file://config.yaml" |
| 10 | |
| 11 | PROVIDES += "virtual/phosphor-ipmi-fru-inventory" |
| 12 | |
| 13 | S = "${WORKDIR}" |
| 14 | |
| 15 | do_install() { |
| 16 | # TODO: install this to inventory_datadir |
| 17 | # after ipmi-fru-parser untangles the host |
| 18 | # firmware config from the machine inventory. |
| 19 | DEST=${D}${config_datadir} |
| 20 | |
| 21 | install -d ${DEST} |
| 22 | install config.yaml ${DEST} |
| 23 | } |
| 24 | |