Brad Bishop | 6e05ef2 | 2020-04-22 14:06:02 -0400 | [diff] [blame] | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:" |
| 2 | |
| 3 | PACKAGECONFIG_append_witherspoon-128 = " host-dump-offload-pldm" |
| 4 | PACKAGECONFIG_append_rainier = " host-dump-offload-pldm" |
| 5 | PACKAGECONFIG_append_witherspoon-tacoma = " host-dump-offload-pldm" |
Matt Spinler | 036c8f9 | 2018-03-29 16:34:38 -0500 | [diff] [blame] | 6 | |
| 7 | SRC_URI += "file://plugins.d/ibm_elogall" |
| 8 | |
| 9 | install_ibm_plugins() { |
| 10 | |
| 11 | install -m 0755 ${WORKDIR}/plugins.d/ibm_elogall ${D}${dreport_plugin_dir} |
| 12 | |
| 13 | } |
| 14 | |
| 15 | #Link in the plugins so dreport run them at the appropriate time |
| 16 | python link_ibm_plugins() { |
| 17 | |
| 18 | workdir = d.getVar('WORKDIR', True) |
| 19 | script = os.path.join(workdir, 'plugins.d', 'ibm_elogall') |
| 20 | install_dreport_user_script(script, d) |
Matt Spinler | 036c8f9 | 2018-03-29 16:34:38 -0500 | [diff] [blame] | 21 | } |
| 22 | |
| 23 | do_install[postfuncs] += "install_ibm_plugins" |
| 24 | do_install[postfuncs] += "link_ibm_plugins" |