Brandon Wyman | 23db01f | 2017-06-09 17:50:42 -0500 | [diff] [blame] | 1 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" |
Brandon Wyman | 37e55d8 | 2017-04-28 18:26:45 -0500 | [diff] [blame] | 2 | |
| 3 | # Package configuration |
| 4 | FAN_PACKAGES += " \ |
| 5 | phosphor-cooling-type \ |
| 6 | " |
Brandon Wyman | 23db01f | 2017-06-09 17:50:42 -0500 | [diff] [blame] | 7 | |
| 8 | PACKAGECONFIG += "cooling-type" |
| 9 | |
Brandon Wyman | 23db01f | 2017-06-09 17:50:42 -0500 | [diff] [blame] | 10 | TMPL_COOLING = "phosphor-cooling-type@.service" |
| 11 | INSTFMT_COOLING = "phosphor-cooling-type@{0}.service" |
Patrick Venture | 85cff8c | 2019-04-04 13:06:43 -0700 | [diff] [blame] | 12 | COOLING_TGT = "multi-user.target" |
Brandon Wyman | 23db01f | 2017-06-09 17:50:42 -0500 | [diff] [blame] | 13 | FMT_COOLING = "../${TMPL_COOLING}:${COOLING_TGT}.requires/${INSTFMT_COOLING}" |
Brandon Wyman | 37e55d8 | 2017-04-28 18:26:45 -0500 | [diff] [blame] | 14 | |
Patrick Venture | 8c065e2 | 2019-03-30 08:57:39 -0700 | [diff] [blame] | 15 | FILES_phosphor-cooling-type = "${bindir}/phosphor-cooling-type" |
Brandon Wyman | 23db01f | 2017-06-09 17:50:42 -0500 | [diff] [blame] | 16 | SYSTEMD_SERVICE_phosphor-cooling-type += "${TMPL_COOLING}" |
| 17 | SYSTEMD_LINK_phosphor-cooling-type += "${@compose_list(d, 'FMT_COOLING', 'OBMC_CHASSIS_INSTANCES')}" |
Brandon Wyman | 37e55d8 | 2017-04-28 18:26:45 -0500 | [diff] [blame] | 18 | |
| 19 | COOLING_ENV_FMT = "obmc/phosphor-fan/phosphor-cooling-type-{0}.conf" |
| 20 | |
Brandon Wyman | 23db01f | 2017-06-09 17:50:42 -0500 | [diff] [blame] | 21 | SYSTEMD_ENVIRONMENT_FILE_phosphor-cooling-type += "${@compose_list(d, 'COOLING_ENV_FMT', 'OBMC_CHASSIS_INSTANCES')}" |
Brandon Wyman | 37e55d8 | 2017-04-28 18:26:45 -0500 | [diff] [blame] | 22 | |
Matthew Barth | ceacb77 | 2017-10-24 14:07:09 -0500 | [diff] [blame] | 23 | #These services are protected by the watchdog |
Matt Spinler | 736d3e0 | 2018-05-02 16:06:36 -0500 | [diff] [blame] | 24 | SYSTEMD_OVERRIDE_phosphor-fan-control += "fan-watchdog-monitor.conf:phosphor-fan-control-init@0.service.d/fan-watchdog-monitor.conf" |
Matt Spinler | 9bce4f8 | 2017-06-08 12:46:22 -0500 | [diff] [blame] | 25 | SYSTEMD_OVERRIDE_phosphor-fan-control += "fan-watchdog-monitor.conf:phosphor-fan-control@0.service.d/fan-watchdog-monitor.conf" |
Matt Spinler | 736d3e0 | 2018-05-02 16:06:36 -0500 | [diff] [blame] | 26 | SYSTEMD_OVERRIDE_phosphor-fan-monitor += "fan-watchdog-monitor.conf:phosphor-fan-monitor-init@0.service.d/fan-watchdog-monitor.conf" |
Matt Spinler | 9bce4f8 | 2017-06-08 12:46:22 -0500 | [diff] [blame] | 27 | SYSTEMD_OVERRIDE_phosphor-fan-monitor += "fan-watchdog-monitor.conf:phosphor-fan-monitor@0.service.d/fan-watchdog-monitor.conf" |
Matt Spinler | d9aee4a | 2017-06-19 14:55:52 -0500 | [diff] [blame] | 28 | |
Matthew Barth | ceacb77 | 2017-10-24 14:07:09 -0500 | [diff] [blame] | 29 | #These services need to be stopped when watchdog expires |
| 30 | SYSTEMD_OVERRIDE_phosphor-fan-control += "fan-watchdog-conflicts.conf:phosphor-fan-control@0.service.d/fan-watchdog-conflicts.conf" |
Matt Spinler | d9aee4a | 2017-06-19 14:55:52 -0500 | [diff] [blame] | 31 | SYSTEMD_OVERRIDE_phosphor-fan-monitor += "fan-watchdog-conflicts.conf:phosphor-fan-monitor@0.service.d/fan-watchdog-conflicts.conf" |