Matt Spinler | 17de1eb | 2017-06-06 09:40:45 -0500 | [diff] [blame] | 1 | SUMMARY = "Witherspoon fan watchdog services" |
| 2 | PR = "r1" |
| 3 | |
| 4 | inherit obmc-phosphor-license |
| 5 | inherit obmc-phosphor-systemd |
| 6 | |
| 7 | RDEPENDS_${PN} += "phosphor-gpio-monitor" |
| 8 | |
| 9 | RESET_SERVICE = "witherspoon-reset-fan-watchdog.service" |
| 10 | TGTFMT = "obmc-chassis-poweron@0.target" |
| 11 | RESET_FMT = "../${RESET_SERVICE}:${TGTFMT}.requires/${RESET_SERVICE}" |
| 12 | |
| 13 | SYSTEMD_SERVICE_${PN} += "${RESET_SERVICE}" |
| 14 | SYSTEMD_LINK_${PN} += "${RESET_FMT}" |
| 15 | SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/witherspoon-fan-watchdog/witherspoon-reset-fan-watchdog.conf" |