blob: 0133c87fce16a914ea0865d511381a0a5cd9fecf [file] [log] [blame]
Matt Spinler59349792016-08-11 14:16:42 -05001SUMMARY = "Palmetto System Inventory"
2DESCRIPTION = "Provides the inventory file for Palmetto"
3PR = "r1"
4
5inherit obmc-phosphor-license
6inherit allarch
7
8RPROVIDES_${PN} = "virtual-system-inventory-data"
9
10SRC_URI += "file://palmetto_inventory.json"
11
12FILES_${PN} += "${datadir}/inventory"
13
14do_install() {
15 install -d ${D}${datadir}/inventory
16 install -m 0644 palmetto_inventory.json ${D}${datadir}/inventory/inventory.json
17}
18
19S = "${WORKDIR}"