Brad Bishop | 6eb25f4 | 2017-01-28 13:00:52 -0500 | [diff] [blame] | 1 | SUMMARY = "Palmetto IPMI to DBus Inventory mapping." |
| 2 | PR = "r1" |
| 3 | |
| 4 | inherit native |
| 5 | inherit obmc-phosphor-license |
| 6 | inherit phosphor-ipmi-fru |
| 7 | |
| 8 | SRC_URI += "file://config.yaml" |
| 9 | |
| 10 | PROVIDES += "virtual/phosphor-ipmi-fru-inventory" |
| 11 | |
| 12 | S = "${WORKDIR}" |
| 13 | |
| 14 | do_install() { |
| 15 | # TODO: install this to inventory_datadir |
| 16 | # after ipmi-fru-parser untangles the host |
| 17 | # firmware config from the machine inventory. |
| 18 | DEST=${D}${config_datadir} |
| 19 | |
| 20 | install -d ${DEST} |
| 21 | install config.yaml ${DEST} |
| 22 | } |
| 23 | |