blob: efbdea1f3ec5430cd2d7476e472ee197c79b88f5 [file] [log] [blame]
Brad Bishop6587e6c2019-05-13 14:46:48 -04001FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
Matthew Bartha6817ca2020-01-14 14:21:46 -06002
3SRC_URI_witherspoon = "file://config.json"
Matthew Barthdd3117e2020-11-23 19:40:56 -06004SRC_URI_rainier = "file://rainier-2u/config.json \
5 file://rainier-4u/config.json \
6 file://everest/config.json \
7 "
Matthew Bartha6817ca2020-01-14 14:21:46 -06008
9do_install_witherspoon() {
10 install -d ${D}/${datadir}/phosphor-fan-presence/presence/
11 install -m 0644 ${WORKDIR}/config.json ${D}/${datadir}/phosphor-fan-presence/presence/
12}
Matthew Barthdd3117e2020-11-23 19:40:56 -060013do_install_rainier() {
14 # Install Rainier-2U/4U fan presence config files
15 install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/
16 install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/
17 install -m 0644 ${WORKDIR}/rainier-2u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/
18 install -m 0644 ${WORKDIR}/rainier-4u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/
19
20 # Install Everest fan presence config file
21 install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,everest/
22 install -m 0644 ${WORKDIR}/everest/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,everest/
23}
Matthew Bartha6817ca2020-01-14 14:21:46 -060024
25FILES_${PN}_append_witherspoon = " ${datadir}/phosphor-fan-presence/presence/config.json"
26FILES_${PN}_remove_witherspoon = "${presence_datadir}/config.yaml"
Matthew Barthdd3117e2020-11-23 19:40:56 -060027
28FILES_${PN}_remove_rainier = "${presence_datadir}/config.yaml"
29FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/config.json"
30FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/config.json"
31FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,everest/config.json"