blob: 57ee0fe12f9ed152e925c1328313ff36929e09c7 [file] [log] [blame]
Matt Spinlereea390f2017-08-14 13:27:09 -05001SUMMARY = "Witherspoon Power Fault Analysis"
2DESCRIPTION = "Analyzes power devices for faults"
3PR = "r1"
4
5inherit autotools
6inherit pkgconfig
7inherit obmc-phosphor-systemd
8inherit pythonnative
9
10require ${PN}.inc
11
12S = "${WORKDIR}/git"
13
14DEPENDS += " \
15 phosphor-logging \
16 autoconf-archive-native \
17 sdbus++-native \
18 "
19
20RDEPENDS_${PN} += " \
21 phosphor-logging \
22 phosphor-dbus-interfaces \
23 sdbusplus \
24 "
25
26CHASSIS_ON_TGT = "obmc-chassis-poweron@0.target"
27SEQ_PGOOD_SVC = "witherspoon-pseq-monitor-pgood.service"
28SEQ_PGOOD_FMT = "../${SEQ_PGOOD_SVC}:${CHASSIS_ON_TGT}.wants/${SEQ_PGOOD_SVC}"
29
30SYSTEMD_SERVICE_${PN} += "${SEQ_PGOOD_SVC}"
31SYSTEMD_LINK_${PN} += "${SEQ_PGOOD_FMT}"