| SUMMARY = "dbus-sensors" |
| DESCRIPTION = "Dbus Sensor Services Configured from D-Bus" |
| |
| SRC_URI = "git://github.com/openbmc/s2600wf-misc.git" |
| SRCREV = "b7bd2a88226a613091caabce5d1e236d67266ac0" |
| |
| PV = "0.1+git${SRCPV}" |
| |
| LICENSE = "Apache-2.0" |
| LIC_FILES_CHKSUM = "file://../LICENCE;md5=86d3f3a95c324c9479bd8986968f4327" |
| |
| SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.fansensor.service" |
| SYSTEMD_SERVICE_${PN} += " xyz.openbmc_project.adcsensor.service" |
| SYSTEMD_SERVICE_${PN} += " xyz.openbmc_project.hwmontempsensor.service" |
| SYSTEMD_SERVICE_${PN} += " xyz.openbmc_project.cpusensor.service" |
| |
| DEPENDS = "boost nlohmann-json sdbusplus" |
| inherit cmake obmc-phosphor-systemd |
| |
| S = "${WORKDIR}/git/sensors" |
| |
| # linux-libc-headers guides this way to include custom uapi headers |
| CXXFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include/uapi" |
| CXXFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include" |
| do_configure[depends] += "virtual/kernel:do_shared_workdir" |