James Feist | 3164a56 | 2018-10-03 14:53:29 -0700 | [diff] [blame] | 1 | SUMMARY = "dbus-sensors" |
| 2 | DESCRIPTION = "Dbus Sensor Services Configured from D-Bus" |
| 3 | |
| 4 | SRC_URI = "git://github.com/openbmc/s2600wf-misc.git" |
Andrew Geissler | 3aea871 | 2018-11-23 21:10:09 +0000 | [diff] [blame^] | 5 | SRCREV = "b7bd2a88226a613091caabce5d1e236d67266ac0" |
James Feist | 3164a56 | 2018-10-03 14:53:29 -0700 | [diff] [blame] | 6 | |
| 7 | PV = "0.1+git${SRCPV}" |
| 8 | |
| 9 | LICENSE = "Apache-2.0" |
| 10 | LIC_FILES_CHKSUM = "file://../LICENCE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 11 | |
| 12 | SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.fansensor.service" |
| 13 | SYSTEMD_SERVICE_${PN} += " xyz.openbmc_project.adcsensor.service" |
| 14 | SYSTEMD_SERVICE_${PN} += " xyz.openbmc_project.hwmontempsensor.service" |
| 15 | SYSTEMD_SERVICE_${PN} += " xyz.openbmc_project.cpusensor.service" |
| 16 | |
| 17 | DEPENDS = "boost nlohmann-json sdbusplus" |
| 18 | inherit cmake obmc-phosphor-systemd |
| 19 | |
| 20 | S = "${WORKDIR}/git/sensors" |
| 21 | |
| 22 | # linux-libc-headers guides this way to include custom uapi headers |
| 23 | CXXFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include/uapi" |
| 24 | CXXFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include" |
| 25 | do_configure[depends] += "virtual/kernel:do_shared_workdir" |