blob: bbd73a1f7fd892da92dd477a945ff883b02c7268 [file] [log] [blame]
AppaRao Puli17eab242020-05-28 01:02:47 +05301SUMMARY = "Service configuration manager daemon to control service properties"
2DESCRIPTION = "Daemon controls service properies like port, channels, state etc.."
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
6inherit cmake systemd
7
8SRC_URI = "git://github.com/openbmc/service-config-manager"
9
10PV = "0.1+git${SRCPV}"
11SRCREV = "33816cf9125737e9ec931961bad2924a6104c5bb"
12
13S = "${WORKDIR}/git"
14
15SYSTEMD_SERVICE_${PN} = "srvcfg-manager.service"
16
17DEPENDS += " \
18 systemd \
19 sdbusplus \
20 sdbusplus-native \
21 phosphor-logging \
22 boost \
23 "
24RDEPENDS_${PN} += " \
25 libsystemd \
26 sdbusplus \
27 phosphor-logging \
28 "