blob: c44f57af441874fc748f5a68d4eb10651df38e8a [file] [log] [blame]
James Feist3164a562018-10-03 14:53:29 -07001SUMMARY = "dbus-sensors"
2DESCRIPTION = "Dbus Sensor Services Configured from D-Bus"
3
4SRC_URI = "git://github.com/openbmc/s2600wf-misc.git"
Andrew Geissler3aea8712018-11-23 21:10:09 +00005SRCREV = "b7bd2a88226a613091caabce5d1e236d67266ac0"
James Feist3164a562018-10-03 14:53:29 -07006
7PV = "0.1+git${SRCPV}"
8
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://../LICENCE;md5=86d3f3a95c324c9479bd8986968f4327"
11
12SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.fansensor.service"
13SYSTEMD_SERVICE_${PN} += " xyz.openbmc_project.adcsensor.service"
14SYSTEMD_SERVICE_${PN} += " xyz.openbmc_project.hwmontempsensor.service"
15SYSTEMD_SERVICE_${PN} += " xyz.openbmc_project.cpusensor.service"
16
17DEPENDS = "boost nlohmann-json sdbusplus"
18inherit cmake obmc-phosphor-systemd
19
20S = "${WORKDIR}/git/sensors"
21
22# linux-libc-headers guides this way to include custom uapi headers
23CXXFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include/uapi"
24CXXFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include"
25do_configure[depends] += "virtual/kernel:do_shared_workdir"