Yong Li | c5a33a9 | 2019-01-03 11:41:48 +0800 | [diff] [blame] | 1 | SUMMARY = "Intel DBus Interfaces" |
| 2 | DESCRIPTION = "Generated bindings, using sdbus++, for the Intel YAML" |
| 3 | PR = "r1" |
| 4 | PV = "1.0+git${SRCPV}" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 7 | |
| 8 | S = "${WORKDIR}/git" |
| 9 | |
| 10 | inherit autotools pkgconfig |
Patrick Williams | e7eeb88 | 2020-03-31 16:43:15 -0500 | [diff] [blame] | 11 | inherit python3native |
Yong Li | c5a33a9 | 2019-01-03 11:41:48 +0800 | [diff] [blame] | 12 | inherit phosphor-dbus-yaml |
| 13 | |
| 14 | DEPENDS += "autoconf-archive-native" |
Patrick Williams | e7eeb88 | 2020-03-31 16:43:15 -0500 | [diff] [blame] | 15 | DEPENDS += "${PYTHON_PN}-sdbus++-native" |
Yong Li | c5a33a9 | 2019-01-03 11:41:48 +0800 | [diff] [blame] | 16 | |
| 17 | SRC_URI = "git://github.com/openbmc/intel-dbus-interfaces" |
Andrew Geissler | 06cb787 | 2019-06-10 01:00:56 +0000 | [diff] [blame] | 18 | SRCREV = "b5f2dd444c5d3808d005452417e4ae2ea28624ff" |
Yong Li | c5a33a9 | 2019-01-03 11:41:48 +0800 | [diff] [blame] | 19 | |
Yong Li | c5a33a9 | 2019-01-03 11:41:48 +0800 | [diff] [blame] | 20 | PACKAGECONFIG ??= "libintel_dbus" |
| 21 | PACKAGECONFIG[libintel_dbus] = " \ |
| 22 | --enable-libintel_dbus, \ |
| 23 | --disable-libintel_dbus, \ |
| 24 | systemd sdbusplus, \ |
Patrick Williams | e7eeb88 | 2020-03-31 16:43:15 -0500 | [diff] [blame] | 25 | libsystemd \ |
Yong Li | c5a33a9 | 2019-01-03 11:41:48 +0800 | [diff] [blame] | 26 | " |
| 27 | |
| 28 | PACKAGECONFIG_remove_class-native = "libintel_dbus" |
| 29 | PACKAGECONFIG_remove_class-nativesdk = "libintel_dbus" |
| 30 | |
Patrick Williams | e7eeb88 | 2020-03-31 16:43:15 -0500 | [diff] [blame] | 31 | BBCLASSEXTEND += "native nativesdk" |