blob: 56e5dd259143daf10254c1415d095d4a5a760c13 [file] [log] [blame]
Brian Yang9d478082018-07-28 04:01:57 -04001SUMMARY = "Lanyang IPMI to DBus Inventory mapping."
2PR = "r1"
Patrick Venture29d75662018-11-06 09:38:04 -08003LICENSE = "Apache-2.0"
Brad Bishop87316ec2019-09-13 14:04:55 -04004LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Brian Yang9d478082018-07-28 04:01:57 -04005
6inherit native
Brian Yang9d478082018-07-28 04:01:57 -04007inherit phosphor-ipmi-fru
8
9SRC_URI += "file://config.yaml"
10
11PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
12
13S = "${WORKDIR}"
14
15do_install() {
16 # TODO: install this to inventory_datadir
17 # after ipmi-fru-parser untangles the host
18 # firmware config from the machine inventory.
19 DEST=${D}${config_datadir}
20
21 install -d ${DEST}
22 install config.yaml ${DEST}
23}
24