Marri Devender Rao | 6a48c3c | 2017-04-27 03:38:39 -0500 | [diff] [blame] | 1 | SUMMARY = "OpenPOWER Debug Collector" |
Vishwanatha Subbanna | 3a532e9 | 2017-06-13 15:00:24 +0530 | [diff] [blame] | 2 | DESCRIPTION = "Application to log error during host checkstop and watchdog timeout" |
Marri Devender Rao | 6a48c3c | 2017-04-27 03:38:39 -0500 | [diff] [blame] | 3 | |
| 4 | PR = "r1" |
| 5 | |
| 6 | inherit autotools \ |
| 7 | pkgconfig \ |
| 8 | obmc-phosphor-systemd \ |
Marri Devender Rao | 9d87330 | 2017-05-14 08:53:45 -0500 | [diff] [blame] | 9 | pythonnative |
Marri Devender Rao | 6a48c3c | 2017-04-27 03:38:39 -0500 | [diff] [blame] | 10 | |
| 11 | require ${PN}.inc |
| 12 | |
| 13 | DEPENDS += " \ |
| 14 | phosphor-logging \ |
| 15 | autoconf-archive-native \ |
Marri Devender Rao | 9d87330 | 2017-05-14 08:53:45 -0500 | [diff] [blame] | 16 | sdbus++-native \ |
Marri Devender Rao | 6a48c3c | 2017-04-27 03:38:39 -0500 | [diff] [blame] | 17 | " |
Marri Devender Rao | 6a48c3c | 2017-04-27 03:38:39 -0500 | [diff] [blame] | 18 | RDEPENDS_${PN} += " \ |
| 19 | phosphor-logging \ |
| 20 | " |
| 21 | |
| 22 | S = "${WORKDIR}/git" |
| 23 | |
Vishwanatha Subbanna | be519ef | 2017-06-13 14:11:06 +0530 | [diff] [blame] | 24 | # This provides below 2 applications that are called into in case |
| 25 | # of host checkstop and host watchdog timeout respectively. |
| 26 | APPS = "checkstop watchdog" |
Marri Devender Rao | 6a48c3c | 2017-04-27 03:38:39 -0500 | [diff] [blame] | 27 | |
Vishwanatha Subbanna | be519ef | 2017-06-13 14:11:06 +0530 | [diff] [blame] | 28 | DEBUG_TMPL = "openpower-debug-collector-{0}@.service" |
| 29 | SYSTEMD_SERVICE_${PN} += "${@compose_list(d, 'DEBUG_TMPL', 'APPS')}" |
| 30 | |
| 31 | # This needs to be executed as part of host crash |
| 32 | CHECKSTOP_TMPL = "openpower-debug-collector-checkstop@.service" |
| 33 | CRASH_TGTFMT = "obmc-host-crash@{0}.target" |
| 34 | CHECKSTOP_INSTFMT = "openpower-debug-collector-checkstop@{0}.service" |
| 35 | CRASH_CHECKSTOP_FMT = "../${CHECKSTOP_TMPL}:${CRASH_TGTFMT}.wants/${CHECKSTOP_INSTFMT}" |
| 36 | |
Vishwanatha Subbanna | 3a532e9 | 2017-06-13 15:00:24 +0530 | [diff] [blame] | 37 | # Make watchdog part of obmc-host-timeout target |
Vishwanatha Subbanna | be519ef | 2017-06-13 14:11:06 +0530 | [diff] [blame] | 38 | WDOG_TMPL = "openpower-debug-collector-watchdog@.service" |
Vishwanatha Subbanna | 3a532e9 | 2017-06-13 15:00:24 +0530 | [diff] [blame] | 39 | TIMEOUT_TGTFMT = "obmc-host-timeout@{0}.target" |
Vishwanatha Subbanna | be519ef | 2017-06-13 14:11:06 +0530 | [diff] [blame] | 40 | WDOG_INSTFMT = "openpower-debug-collector-watchdog@{0}.service" |
Vishwanatha Subbanna | 3a532e9 | 2017-06-13 15:00:24 +0530 | [diff] [blame] | 41 | TIMEOUT_WDOG_FMT = "../${WDOG_TMPL}:${TIMEOUT_TGTFMT}.wants/${WDOG_INSTFMT}" |
Vishwanatha Subbanna | be519ef | 2017-06-13 14:11:06 +0530 | [diff] [blame] | 42 | |
| 43 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'CRASH_CHECKSTOP_FMT', 'OBMC_HOST_INSTANCES')}" |
Vishwanatha Subbanna | 3a532e9 | 2017-06-13 15:00:24 +0530 | [diff] [blame] | 44 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'TIMEOUT_WDOG_FMT', 'OBMC_HOST_INSTANCES')}" |