| SUMMARY = "Phosphor OEM IPMI Ethernet Stats Implementation" |
| DESCRIPTION = "This package handles receiving OEM IPMI commands to provide ethernet device statistics." |
| HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-ethstats" |
| PR = "r1" |
| PV = "0.1+git${SRCPV}" |
| LICENSE = "Apache-2.0" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| |
| inherit autotools pkgconfig |
| inherit obmc-phosphor-ipmiprovider-symlink |
| |
| DEPENDS += "autoconf-archive-native" |
| DEPENDS += "phosphor-ipmi-host" |
| |
| S = "${WORKDIR}/git" |
| SRC_URI = "git://github.com/openbmc/phosphor-ipmi-ethstats" |
| SRCREV = "d26fff4ecd74aa72433bcb547d95029e4b7b0eb3" |
| |
| FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}" |
| FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |
| |
| HOSTIPMI_PROVIDER_LIBRARY += "libethstatscmd.so" |