Patrick Venture | af57049 | 2018-09-22 18:56:00 -0700 | [diff] [blame] | 1 | SUMMARY = "Phosphor OEM IPMI Ethernet Stats Implementation" |
| 2 | DESCRIPTION = "This package handles receiving OEM IPMI commands to provide ethernet device statistics." |
| 3 | HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-ethstats" |
| 4 | PR = "r1" |
| 5 | PV = "0.1+git${SRCPV}" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 8 | |
| 9 | inherit autotools pkgconfig |
| 10 | inherit obmc-phosphor-ipmiprovider-symlink |
| 11 | |
| 12 | DEPENDS += "autoconf-archive-native" |
| 13 | DEPENDS += "phosphor-ipmi-host" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | SRC_URI = "git://github.com/openbmc/phosphor-ipmi-ethstats" |
| 17 | SRCREV = "d26fff4ecd74aa72433bcb547d95029e4b7b0eb3" |
| 18 | |
| 19 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 20 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 21 | FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}" |
| 22 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |
| 23 | |
| 24 | HOSTIPMI_PROVIDER_LIBRARY += "libethstatscmd.so" |