blob: fadeb27114aa3fe61816c69d4ea2fa033d1bddb3 [file] [log] [blame]
Adriana Kobylak172fe102016-10-19 14:58:25 -05001SUMMARY = "Logging DBUS Object"
2DESCRIPTION = "Logging DBUS Object"
3HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
4PR = "r1"
5
6inherit autotools pkgconfig
7inherit pythonnative
8inherit obmc-phosphor-license
9inherit obmc-phosphor-dbus-service
10
11DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service"
12
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "systemd"
15DEPENDS += "python-mako-native"
16DEPENDS += "python-pyyaml-native"
17PROVIDES += "virtual/obmc-logging-mgmt"
18RPROVIDES_${PN} += "virtual-obmc-logging-mgmt"
19
20SRC_URI += "git://github.com/openbmc/phosphor-logging"
Patrick Williams0264f342016-12-08 11:50:03 -060021SRCREV = "8f7941edf6843109d3da69900976b04b42d78aa4"
Adriana Kobylak172fe102016-10-19 14:58:25 -050022
23S = "${WORKDIR}/git"
24