blob: 6cb09bc6fa52a732e798d63594270c83a6c3ca1a [file] [log] [blame]
Brad Bishopb0c3b272017-01-11 11:12:32 -05001SUMMARY = "OpenBMC hwmon poller"
2DESCRIPTION = "OpenBMC hwmon poller."
3PR = "r1"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
7
Brad Bishop030da252017-01-11 15:30:07 -05008inherit autotools pkgconfig obmc-phosphor-systemd
9
Brad Bishop1d34ddd2017-08-01 21:33:30 -040010PACKAGE_BEFORE_PN = "max31785-msl"
11SYSTEMD_PACKAGES = "${PN} max31785-msl"
12
Brad Bishop030da252017-01-11 15:30:07 -050013SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Hwmon@.service"
Brad Bishop1d34ddd2017-08-01 21:33:30 -040014SYSTEMD_SERVICE_max31785-msl = "phosphor-max31785-msl@.service"
Brad Bishopb0c3b272017-01-11 11:12:32 -050015
16DEPENDS += "autoconf-archive-native"
Brad Bishopf4393bf2017-02-20 14:36:31 -050017DEPENDS += " \
18 sdbusplus \
19 phosphor-dbus-interfaces \
20 phosphor-logging \
Patrick Venture03c53912018-09-14 09:54:18 -070021 gpioplus \
Brad Bishopf4393bf2017-02-20 14:36:31 -050022 "
23
Brad Bishopb0c3b272017-01-11 11:12:32 -050024
25RDEPENDS_${PN} += "\
Brad Bishopf4393bf2017-02-20 14:36:31 -050026 sdbusplus \
27 phosphor-dbus-interfaces \
28 phosphor-logging \
Patrick Venture03c53912018-09-14 09:54:18 -070029 gpioplus \
Joel Stanley7b29e202017-09-05 17:44:33 +100030 bash \
Brad Bishopb0c3b272017-01-11 11:12:32 -050031 "
32
Brad Bishopfe7871c2017-02-22 20:50:13 -050033RRECOMMENDS_${PN} += "${VIRTUAL-RUNTIME_phosphor-hwmon-config}"
34
Brad Bishop1d34ddd2017-08-01 21:33:30 -040035FILES_max31785-msl = "${bindir}/max31785-msl"
36RDEPENDS_max31785-msl = "${VIRTUAL-RUNTIME_base-utils} i2c-tools"
37
Brad Bishopb0c3b272017-01-11 11:12:32 -050038SRC_URI += "git://github.com/openbmc/phosphor-hwmon"
Brad Bishop030da252017-01-11 15:30:07 -050039SRC_URI += "file://70-hwmon.rules"
Brandon Wyman675ce0b2017-06-21 16:32:56 -050040SRC_URI += "file://70-iio.rules"
Joel Stanley7b29e202017-09-05 17:44:33 +100041SRC_URI += "file://start_hwmon.sh"
Brad Bishopb0c3b272017-01-11 11:12:32 -050042
Andrew Geissler5de553b2018-09-12 14:20:21 +000043SRCREV = "af6227a3eb3fc918425d7588e001a75bd348232d"
Brad Bishopb0c3b272017-01-11 11:12:32 -050044
45S = "${WORKDIR}/git"
Brad Bishop030da252017-01-11 15:30:07 -050046
47do_install_append() {
48
Brad Bishopf5812fd2017-01-26 09:12:57 -050049 install -d ${D}/${base_libdir}/udev/rules.d/
50 install ${WORKDIR}/70-hwmon.rules ${D}/${base_libdir}/udev/rules.d/
Brandon Wyman675ce0b2017-06-21 16:32:56 -050051 install ${WORKDIR}/70-iio.rules ${D}/${base_libdir}/udev/rules.d/
Joel Stanley7b29e202017-09-05 17:44:33 +100052
53 install -d ${D}${bindir}
54 install -m 0755 ${WORKDIR}/start_hwmon.sh ${D}${bindir}
Brad Bishop030da252017-01-11 15:30:07 -050055}