Brad Bishop | f1cc41b | 2017-05-31 14:08:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Phosphor DBus Monitor Configuration" |
| 2 | DESCRIPTION = "Meta-recipe, pulling in native recipes that wish to add \ |
| 3 | configuration files to the /usr/share/phosphor-dbus-monitor filesystem." |
| 4 | HOMEPAGE = "http://github.com/openbmc/phosphor-dbus-monitor" |
| 5 | PR = "r1" |
Patrick Venture | 4d95dbf | 2018-11-03 14:27:24 -0700 | [diff] [blame] | 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658" |
Brad Bishop | f1cc41b | 2017-05-31 14:08:33 -0400 | [diff] [blame] | 8 | |
Brad Bishop | f1cc41b | 2017-05-31 14:08:33 -0400 | [diff] [blame] | 9 | inherit native |
| 10 | inherit phosphor-dbus-monitor |
| 11 | |
| 12 | PHOSPHOR_DBUS_MONITOR_CONFIGS ??= "" |
| 13 | |
| 14 | # To add additional config files, create a recipe in your layer, |
| 15 | # and add it to PHOSPHOR_DBUS_MONITOR_CONFIGS with a bbappend to this recipe. |
| 16 | |
| 17 | DEPENDS += "${PHOSPHOR_DBUS_MONITOR_CONFIGS}" |
| 18 | |
Brad Bishop | ae48606 | 2017-06-26 13:07:50 -0400 | [diff] [blame] | 19 | do_install() { |
| 20 | mkdir -p ${D}${config_dir} |
Brad Bishop | f1cc41b | 2017-05-31 14:08:33 -0400 | [diff] [blame] | 21 | } |