Lei YU | 4d8175e | 2019-10-21 10:39:07 +0800 | [diff] [blame] | 1 | SUMMARY = "Phosphor Power services and utilities" |
| 2 | DESCRIPTION = "Configure and monitor power supplies, power sequencers, and \ |
| 3 | voltage regulators, and analyzes power devices for faults" |
| 4 | PR = "r1" |
| 5 | PV = "1.0+git${SRCPV}" |
| 6 | |
| 7 | inherit meson |
| 8 | inherit pkgconfig |
| 9 | inherit systemd |
| 10 | inherit pythonnative |
| 11 | |
| 12 | require ${PN}.inc |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
Lei YU | 2172cd1 | 2020-02-06 15:43:35 +0800 | [diff] [blame] | 16 | POWER_SERVICE_PACKAGES = " \ |
| 17 | ${PN}-cold-redundancy \ |
| 18 | ${PN}-monitor \ |
| 19 | ${PN}-psu-monitor \ |
| 20 | ${PN}-regulators \ |
| 21 | ${PN}-sequencer \ |
| 22 | " |
| 23 | POWER_UTIL_PACKAGES = "${PN}-utils" |
| 24 | |
| 25 | PACKAGE_BEFORE_PN = "${POWER_SERVICE_PACKAGES} ${POWER_UTIL_PACKAGES}" |
| 26 | ALLOW_EMPTY_${PN} = "1" |
| 27 | |
| 28 | SYSTEMD_PACKAGES = "${POWER_SERVICE_PACKAGES}" |
| 29 | |
Lei YU | 4d8175e | 2019-10-21 10:39:07 +0800 | [diff] [blame] | 30 | # TODO: in future when openpower-dbus-interfaces is removed from |
| 31 | # phosphor-power, remove the dependency here. |
| 32 | DEPENDS += " \ |
| 33 | phosphor-logging \ |
| 34 | openpower-dbus-interfaces \ |
| 35 | sdbus++-native \ |
| 36 | sdeventplus \ |
| 37 | nlohmann-json \ |
Jim Wright | 7a0e57f | 2019-11-06 15:43:43 -0600 | [diff] [blame] | 38 | cli11 \ |
Matthew Barth | 16867e4 | 2019-12-20 15:37:07 -0600 | [diff] [blame] | 39 | i2c-tools \ |
Lei YU | 4d8175e | 2019-10-21 10:39:07 +0800 | [diff] [blame] | 40 | " |
| 41 | |
Lei YU | 4d8175e | 2019-10-21 10:39:07 +0800 | [diff] [blame] | 42 | SEQ_MONITOR_SVC = "pseq-monitor.service" |
| 43 | SEQ_PGOOD_SVC = "pseq-monitor-pgood.service" |
| 44 | PSU_MONITOR_TMPL = "power-supply-monitor@.service" |
Lei YU | 2172cd1 | 2020-02-06 15:43:35 +0800 | [diff] [blame] | 45 | PSU_MONITOR_SVC = "phosphor-psu-monitor.service" |
Matthew Barth | fa58fcd | 2019-12-20 15:42:35 -0600 | [diff] [blame] | 46 | REGS_SVC = "phosphor-regulators.service" |
Lei YU | 2172cd1 | 2020-02-06 15:43:35 +0800 | [diff] [blame] | 47 | |
| 48 | SYSTEMD_SERVICE_${PN}-sequencer = "${SEQ_MONITOR_SVC} ${SEQ_PGOOD_SVC}" |
| 49 | SYSTEMD_SERVICE_${PN}-monitor = "${PSU_MONITOR_TMPL}" |
| 50 | SYSTEMD_SERVICE_${PN}-psu-monitor = "${PSU_MONITOR_SVC}" |
| 51 | SYSTEMD_SERVICE_${PN}-regulators = "${REGS_SVC}" |
| 52 | |
| 53 | |
| 54 | # TODO: cold-redundancy is not installed in the repo yet |
| 55 | # FILES_${PN}-cold-redundancy = "${bindir}/cold-redundancy" |
| 56 | |
| 57 | FILES_${PN}-monitor = "${bindir}/psu-monitor" |
| 58 | FILES_${PN}-psu-monitor = "${bindir}/phosphor-psu-monitor" |
| 59 | FILES_${PN}-regulators = "${bindir}/phosphor-regulators" |
| 60 | FILES_${PN}-sequencer = "${bindir}/pseq-monitor" |
| 61 | FILES_${PN}-utils = "${bindir}/psutils" |
| 62 | FILES_${PN}-regulators = "${datadir}/phosphor-regulators" |