Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 1 | SUMMARY = "Phosphor PID Fan Control" |
| 2 | DESCRIPTION = "Fan Control" |
Patrick Venture | c311dec | 2018-09-29 09:19:22 -0700 | [diff] [blame] | 3 | HOMEPAGE = "github.com/openbmc/phosphor-pid-control" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 4 | PR = "r1" |
Patrick Venture | c311dec | 2018-09-29 09:19:22 -0700 | [diff] [blame] | 5 | PV = "0.1+git${SRCPV}" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 8 | |
| 9 | inherit autotools pkgconfig |
| 10 | inherit pythonnative |
| 11 | |
| 12 | inherit phosphor-pid-control |
| 13 | inherit obmc-phosphor-ipmiprovider-symlink |
| 14 | |
Patrick Venture | c311dec | 2018-09-29 09:19:22 -0700 | [diff] [blame] | 15 | S = "${WORKDIR}/git" |
| 16 | SRC_URI = "git://github.com/openbmc/phosphor-pid-control" |
Andrew Geissler | d2b027e | 2018-11-02 16:40:19 +0000 | [diff] [blame] | 17 | SRCREV = "4b50106d75a57f6985b34f8ddc9b320fdbf41edd" |
Patrick Venture | c311dec | 2018-09-29 09:19:22 -0700 | [diff] [blame] | 18 | |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 19 | # Each platform will need a service file that starts |
| 20 | # at an appropriate time per system. For instance, if |
| 21 | # your system relies on passive dbus for fans or other |
| 22 | # sensors then it may be prudent to wait for all of them. |
| 23 | |
| 24 | DEPENDS += "autoconf-archive-native" |
| 25 | DEPENDS += "python-pyyaml-native" |
| 26 | DEPENDS += "python-mako-native" |
| 27 | DEPENDS += "sdbusplus" |
| 28 | DEPENDS += "phosphor-logging" |
| 29 | DEPENDS += "libevdev" |
| 30 | DEPENDS += "libconfig" |
| 31 | |
| 32 | # We depend on someone providing their system's configuration. |
| 33 | DEPENDS += "virtual/phosphor-fans-sensor-inventory" |
| 34 | # We depend on this to be built first so we can build our providers. |
| 35 | DEPENDS += "phosphor-ipmi-host" |
| 36 | |
| 37 | RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces" |
| 38 | |
| 39 | FILES_${PN} = "${sbindir}/swampd ${sbindir}/setsensor" |
| 40 | |
Patrick Venture | 13a1e6b | 2018-07-27 07:27:01 -0700 | [diff] [blame] | 41 | # The following installs the OEM IPMI handler for the fan controls. |
| 42 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 43 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 44 | FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}" |
| 45 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 46 | |
| 47 | EXTRA_OECONF = "SENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/sensor-list.yaml \ |
| 48 | PID_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/pid-list.yaml \ |
| 49 | ZONE_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/zone-info.yaml" |
| 50 | |
Patrick Venture | 13a1e6b | 2018-07-27 07:27:01 -0700 | [diff] [blame] | 51 | HOSTIPMI_PROVIDER_LIBRARY += "libmanualcmds.so" |