blob: 50f9065654ea60da2983fc915c73bc357d348257 [file] [log] [blame]
Brad Bishop667938f2017-01-12 21:44:51 -05001SUMMARY = "OpenBMC - Applications"
Brad Bishop93fb5352015-09-09 03:59:20 +00002PR = "r1"
3
4inherit packagegroup
5inherit obmc-phosphor-utils
6inherit obmc-phosphor-license
7
Brad Bishop93fb5352015-09-09 03:59:20 +00008PROVIDES = "${PACKAGES}"
9PACKAGES = " \
Brad Bishop46631702017-03-01 16:16:06 -050010 ${PN}-bmc-state-mgmt \
11 ${PN}-chassis-state-mgmt \
Brad Bishop6165ec32016-09-06 22:44:21 -040012 ${PN}-extras \
13 ${PN}-extrasdev \
Brad Bishop11909e02017-05-01 11:54:34 -040014 ${PN}-fan-control \
Brad Bishop46631702017-03-01 16:16:06 -050015 ${PN}-host-state-mgmt \
Brad Bishop45f8b572017-02-01 21:04:14 -050016 ${PN}-inventory \
17 ${PN}-leds \
18 ${PN}-sensors \
Gunnar Millsc868f922017-02-15 16:01:45 -060019 ${PN}-software \
Andrew Geisslera94faf42017-05-08 15:58:01 -050020 ${PN}-host-check-mgmt \
Jayanth Othayoth9963d172017-05-08 09:25:05 -050021 ${PN}-debug-collector \
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -050022 ${PN}-settings \
Ratan Guptab6de45c2017-07-06 21:09:14 +053023 ${PN}-network \
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +053024 ${PN}-user-mgmt \
Brad Bishop93fb5352015-09-09 03:59:20 +000025 "
26
Brad Bishop46631702017-03-01 16:16:06 -050027SUMMARY_${PN}-bmc-state-mgmt = "BMC state management"
28RDEPENDS_${PN}-bmc-state-mgmt = " \
29 ${VIRTUAL-RUNTIME_obmc-bmc-state-manager} \
30 "
31
32SUMMARY_${PN}-chassis-state-mgmt = "Chassis state management"
33RDEPENDS_${PN}-chassis-state-mgmt = " \
34 ${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \
35 "
36
Andrew Geisslera94faf42017-05-08 15:58:01 -050037SUMMARY_${PN}-host-check-mgmt = "Host state check on bmc reset"
38RDEPENDS_${PN}-host-check-mgmt = " \
39 ${VIRTUAL-RUNTIME_obmc-host-check} \
40 "
41
Brad Bishop6165ec32016-09-06 22:44:21 -040042SUMMARY_${PN}-extras = "Extra features"
43RDEPENDS_${PN}-extras = " \
Brad Bishop667938f2017-01-12 21:44:51 -050044 phosphor-rest \
Brad Bishopf1cc41b2017-05-31 14:08:33 -040045 phosphor-dbus-monitor \
Brad Bishop70436da2015-09-16 14:49:27 -040046 "
47
Brad Bishop6165ec32016-09-06 22:44:21 -040048SUMMARY_${PN}-extrasdev = "Development features"
49RDEPENDS_${PN}-extrasdev = " \
Adriana Kobylakeaa56c92016-06-16 14:46:06 -050050 rest-dbus \
51 "
Brad Bishop45f8b572017-02-01 21:04:14 -050052
Brad Bishop11909e02017-05-01 11:54:34 -040053# Use the fan control package group for applications
54# implementing fan control or system fan policy only.
55# Applications that create inventory or sensors should
56# be added those respective package groups instead.
57SUMMARY_${PN}-fan-control = "Fan control"
58RDEPENDS_${PN}-fan-control = " \
Matt Spinlerbd9fdd92017-04-19 08:23:50 -050059 ${VIRTUAL-RUNTIME_obmc-fan-control} \
Matt Spinler39652c82017-05-01 14:29:20 -050060 phosphor-fan-monitor \
Brad Bishop11909e02017-05-01 11:54:34 -040061 "
62
Brad Bishop46631702017-03-01 16:16:06 -050063SUMMARY_${PN}-host-state-mgmt = "Host state management"
64RDEPENDS_${PN}-host-state-mgmt = " \
65 ${VIRTUAL-RUNTIME_obmc-host-state-manager} \
Michael Tritz1f792e02017-03-31 12:04:32 -050066 ${VIRTUAL-RUNTIME_obmc-discover-system-state} \
Brad Bishop46631702017-03-01 16:16:06 -050067 "
68
Brad Bishop45f8b572017-02-01 21:04:14 -050069SUMMARY_${PN}-inventory = "Inventory applications"
70RDEPENDS_${PN}-inventory = " \
71 ${VIRTUAL-RUNTIME_obmc-inventory-manager} \
Matthew Barth91460422017-02-24 13:14:43 -060072 ${VIRTUAL-RUNTIME_obmc-fan-presence} \
Brad Bishop45f8b572017-02-01 21:04:14 -050073 "
74
75SUMMARY_${PN}-leds = "LED applications"
76RDEPENDS_${PN}-leds = " \
Brad Bishopc1d30c52017-02-27 11:59:49 -050077 ${VIRTUAL-RUNTIME_obmc-leds-manager} \
78 ${VIRTUAL-RUNTIME_obmc-leds-sysfs} \
Dhruvaraj Subhashchandrane1266ad2017-04-27 05:29:56 -050079 ${VIRTUAL-RUNTIME_obmc-led-monitor} \
Brad Bishop45f8b572017-02-01 21:04:14 -050080 "
81
82SUMMARY_${PN}-sensors = "Sensor applications"
83RDEPENDS_${PN}-sensors = " \
84 ${VIRTUAL-RUNTIME_obmc-sensors-hwmon} \
85 "
Gunnar Millsc868f922017-02-15 16:01:45 -060086
87SUMMARY_${PN}-software = "Software applications"
88RDEPENDS_${PN}-software = " \
Deepak Kodihalli60d1de52017-04-13 23:23:42 -050089 ${VIRTUAL-RUNTIME_obmc-bmc-download-mgr} \
Gunnar Mills30131f72017-05-15 15:40:58 -050090 ${VIRTUAL-RUNTIME_obmc-bmc-updater} \
Gunnar Millsc868f922017-02-15 16:01:45 -060091 "
Jayanth Othayoth9963d172017-05-08 09:25:05 -050092SUMMARY_${PN}-debug-collector = "BMC debug collector"
93RDEPENDS_${PN}-debug-collector = " \
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -050094 ${VIRTUAL-RUNTIME_obmc-dump-manager} \
95 ${VIRTUAL-RUNTIME_obmc-dump-monitor} \
Jayanth Othayothd2592492017-07-29 22:28:44 -050096 phosphor-debug-collector-dreport \
Vishwanatha Subbanna14609cb2017-05-12 23:31:55 +053097 "
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -050098
99SUMMARY_${PN}-settings = "Settings applications"
100RDEPENDS_${PN}-settings = " \
101 ${VIRTUAL-RUNTIME_obmc-settings-mgr} \
102 "
Ratan Guptab6de45c2017-07-06 21:09:14 +0530103
104SUMMARY_${PN}-network = "BMC Network Manager"
105RDEPENDS_${PN}-network = " \
106 ${VIRTUAL-RUNTIME_obmc-network-manager} \
107 "
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +0530108
109SUMMARY_${PN}-user-mgmt = "User management applications"
110RDEPENDS_${PN}-user-mgmt = " \
111 ${VIRTUAL-RUNTIME_obmc-user-mgmt} \
112 "