blob: 89e94a0b4788fd812ce704bd540f8c7c7064e735 [file] [log] [blame]
Jeremy Kerr49208ee2016-03-17 17:35:27 +08001SUMMARY = "OpenBMC console daemon"
2DESCRIPTION = "Daemon to handle UART console connections"
3HOMEPAGE = "http://github.com/openbmc/obmc-console"
4PR = "r1"
5
6inherit obmc-phosphor-license
7inherit obmc-phosphor-systemd
8inherit autotools
9
10TARGET_CFLAGS += "-fpic -O2"
11
Matthew Barth3cc6f402016-09-26 16:26:27 -050012DEPENDS += "autoconf-archive-native"
13
Jeremy Kerr49208ee2016-03-17 17:35:27 +080014SRC_URI += "git://github.com/openbmc/obmc-console"
Brad Bishop530eb732016-08-30 14:14:24 -040015SRC_URI += "file://${PN}.conf"
Jeremy Kerred9fafd2016-04-12 13:10:12 +080016
Patrick Williams02d6f492016-08-31 09:40:02 -050017SRCREV = "87e344cd6bd848f886e226c8d58ffe4da77ce4bc"
Jeremy Kerr49208ee2016-03-17 17:35:27 +080018
Brad Bishop530eb732016-08-30 14:14:24 -040019SYSTEMD_SERVICE_${PN} = " \
20 ${PN}.service \
21 ${PN}-ssh.socket \
22 ${PN}-ssh@.service \
23 "
Jeremy Kerred9fafd2016-04-12 13:10:12 +080024
Jeremy Kerr49208ee2016-03-17 17:35:27 +080025do_install_append() {
26 install -m 0755 -d ${D}${sysconfdir}
27 install -m 0644 ${WORKDIR}/${PN}.conf ${D}${sysconfdir}/${PN}.conf
Jeremy Kerr49208ee2016-03-17 17:35:27 +080028}
29
30S = "${WORKDIR}/git"